Не устанавливается Battle Net

Доброго времени суток, в связи с вышедшей WoW Classic захотел приобрести и поиграть с друзьями, оплатил подписку на сайте, Скачал клиент Battle Net с официального сайта, но он ни в какую не устанавливается, висит надпись “Обновление агента Blizzard…” и все, висит эта надпись минут 10-20 потом выскакивает “Похоже что-то сломалось”. Пробовал заново скачать клиент, не помогло. ОС Windows 10, Антивируса у меня нет, Брандмауэр отключил ничего не помогает…

Пожалуйста, попробуйте выполнить все перечисленные здесь действия, включая дополнительные.

________________________________________________
Здесь вы можете оставить комментарий относительно предоставленного ответа на форуме.

Мне ничего из этого не помогло, я перепробовал всё.

В таком случае создайте системные файлы MSInfo и DxDiag, загрузите их на файлообменник и опубликуйте ссылку на них здесь. Чтобы опубликовать ссылку, выделите ее в тексте и нажмите кнопку </> на панели редактирования.

________________________________________________
Здесь вы можете оставить комментарий относительно предоставленного ответа на форуме.

Бамп. Испытывал проблему, схожую с ДраконТеней. После долгого перерыва запустил Battle.netApp и получил ошибку “Попытка разбудить агент Близзард…”. Через какое-то время выскакивало “Похоже что-то сломалось”.

Я проверил форумы англоподдержки и последовал совету удалить папку Battle.nеt из ProgramData, мол, проблема может быть в кеше.

Теперь Battlenet отказывается устанавливаться обратно :confused: Появляется окно “Загрузка обновлённых данных…”, но загрузки из интернета не происходит: использование трафика 0 Мбит/сек. Вместо этого создаётся гигантский эррор лог в папке баттл.нета в ProgramData: размеры достигают десятка ГБ, но повторяются всего несколько строк.

Файлы МсИнфо, ДхДиаг, обрезанный лог из ProgramData и внешний вид окна “Загрузка обновлённых данных” - прикрепляются.
https://yadi.sk/d/H3Ba7_7L7Rk-VA

Ред.: драйвера обновлял, антивирь обновлял, ОС обновлял (Win10), антивирь удалял (Avast) - безрезультатно. Стоит ли терять надежду поиграть в игры близзард?

У Вас запущены две защитные программы параллельно - подобное может провоцировать неполадки не только с играми, но и в целом стать причиной конфликтов этих программ друг с другом. Попробуйте на время полностью отключить обе программы - и Avast, и встроенный Защитник Windows.

Затем активируйте службу Вторичный вход в систему - она необходима для корректной загрузки и запуска наших приложений.

После этого попробуйте выполнить “чистую” установку приложения:

  • удалите приложение Blizzard по этой инструкции;

  • удалите папки Battle.nеt, Blizzard и Blizzard Entertainment (если они есть) из следующих директорий*:

    C:\ProgramData
    C:\Пользователи\ВашеИмяПользователя\AppData\Roaming
    C:\Пользователи\ВашеИмяПользователя\AppData\LocalLow
    C:\Пользователи\ВашеИмяПользователя\AppData\Local
    C:\Пользователи\ВашеИмяПользователя\AppData\Local\Temp

  • запустите установку приложения от имени администратора (ПКМ по иконке приложения -> Запустить от имени администратора), выбрав в качестве пути установки корень диска C.

* Папки ProgramData и AppData могут быть скрыты по умолчанию. Чтобы сделать их видимыми, воспользуйтесь этой инструкцией.

________________________________________________
Здесь вы можете оставить комментарий относительно предоставленного ответа на форуме.

Лайков: 1

Спасибо, Солентель! Я и понятия не имел, что мой Windows Defender очнулся от сна.

Спустя время:
Проблема заключалась в том, что даже после отключения Windows Defender через regedit и отказа от всех форм защиты в Центре обновления, Виндоус оставляла активным Брандмауэр частных сетей, который надо отключать отдельно. Похоже, именно поэтому у некоторых пользователей со схожей проблемой получалось установить Баттл.нет при смене типа подключения к интернету.

Ещё раз спасибо техподдержке, я счастлив, всё работает http://prntscr.com/p40kka

не получается установить баттл нет, испробовал все выше написанное и не только , зависает на обновлении агента близзард
https://dropmefiles.com/ojDyE

Лайков: 1

такая же фигня как обновилась 10 винда

Здравствуйте, VIP.

К сожалению, мне не удалось проверить предоставленные Вами файлы. По всей видимости, слишком много информации было вырезано из файла MSInfo. Пожалуйста, ещё раз создайте файлы, загрузите их на файлообменник и опубликуйте здесь ссылку.

Здравствуйте, sparta89.

Пожалуйста, выполните рекомендации предложенные моей коллегой выше. В случае, если положительного результата не будет, создайте системные файлы MSInfo и DxDiag, загрузите их на файлообменник и опубликуйте ссылку на них здесь. Чтобы опубликовать ссылку, выделите ее в тексте и нажмите кнопку </> на панели редактирования. Также, пожалуйста, как можно подробнее опишите затруднение с которым Вы столкнулись.

https://upload.in.ua/8CxwXDzVP повторно загрузил

Увы, в загруженных Вами файлах вновь отсутствует информация. Это может говорить о неполадках с WMI (инструментарий управления Windows), которые также могут вызывать и затруднения с установкой приложения. Давайте попробуем сделать сброс WMI:

  1. Нажмите кнопку Пуск на клавиатуре или комбинацию клавиш Win+Q.

  2. В строке поиска впишите CMD.

  3. Нажмите правой кнопкой мыши по пункту Командная строка (Command Prompt) и выберите опцию Запуск от имени Администратора.

  4. Введите следующие команды, нажимая Enter после ввода каждой из них. Если появится дополнительное окно для подтверждения команды, пожалуйста, нажмите Да или OK:

    • net stop winmgmt
    • winmgmt /resetrepository
    • net start winmgmt

Одна из команд может сообщить, что служба WMI уже запущена - это нормально.

После того как все команды будут введены, пожалуйста, закройте окно командной строки, перезагрузите свой компьютер и попробуйте запустить приложение Blizzard.

________________________________________________
Здесь вы можете оставить комментарий относительно предоставленного ответа на форуме.

все сделал, дополнительно включил wmi в службах, но не помогло . че происходит вообще не понимаю)) решил вернуться после легиона и такая подстава что даже лаунчер не могу установить)

Если Вы сбросили WMI, то теперь информация в системных файлах должна отображаться корректно. Пожалуйста, создайте их еще раз и поделитесь ссылкой на них.

________________________________________________
Здесь вы можете оставить комментарий относительно предоставленного ответа на форуме.

сведения по msinfo не собирались поэтому решил запустить утилиту WMIdiag я сам ничего не понимаю но буду благодарен за помощь ссылка на результат https://dropmefiles.com/j69fj

КОшмар!! почему я должен крутить, вертеть виндовс, когда такой Близард с кривым лаунчером!! от всех производителей, лаунчеры нормально работают! только Близард начиная с 2012 года, мозг е…т!!! УЧИТЕСЬ УЖЕ У СТИМА, как ПРАВИЛЬНО ДЕЛАТЬ ЛАУНЧЕР ДЛЯ ИГР!!!
Вот так вы и теряете ПОДПИСЧИКОВ!!!

Вы не правы! я не 1 раз переустанавливал Батлнет и защита антивируса не причем!! у вас проблемы на серверах - данные не скачиваются, проблема у вас, но вы умудряетесь обманом увернуться! Очень плохо! вы лицо компании и показываете вашу компанию не с лучшей стороны!
Можете не спорить! З.П.П. - клиент всегда прав!!!

Лайков: 1

Такая же дичь, пытался установить овер, шла просто бесконечная загрузка. Потом решил переустановить батл нет, в результате загрузка доходит до 70% и замораживается.

Тоже начались проблемы, сам начудил.
Спасибо за решение.

  1. Удалил все папки с BattleNet и Blizzard из тех 4 папок. что вы указали.
  2. Отключил брендмауэр (он, сволочь, блокировал сетевое подключение)

Всё работает.