Diablo 3 crashes on launch


#1

I suddenly have this issue when I try to start Diablo 3.
The D3 logo shows up for a few seconds the screen turns grey(as it always does before D3 opens), the I’m kicked back to desktop.
Never encountered this before. Can’t think of anything I’ve done since yesterday evening that could explain this.

Any tips?
Thanks.


Crashes on start up
#2

Heya,

Give the steps listed in our Diablo III Locked Up Support article a go, and uninstall the Razer Chroma SDK service if you have that active. Retest once done.

If that still does not help out, post your System Files so we can have a closer look into this. Please go through the steps listed here, and create both the MSInfo and DxDiag files. Post them on a page like Pastebin.com or share directly with us through OneDrive. Post the links here afterwards as preformatted text (text between ``), so we can have a look.


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi


#3

Well, I don’t know why but after enabling Razer Chroma SDK Service it finally opened up.
Not sure if this was a coincidence, but for now it’s solved.


#4

Happy to hear that. :slight_smile:


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi


#5

Hi,
I have been having a issue with my d3, I have reinstalled and updated windows and driver, scanned and repaired with no luck, I tried closing all background apps also, can you help please?

https://pastebin.com/qya91ugZ


#6

Just bumping my post as it still is not working tried memory scan tool also. Did not bring up any errors :frowning:


#7

Hey Sh3lbinat0r,

What happens when you try to play Diablo III, what is the actual issue you are having?


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi


#8

on the start up screen at server authentication it crashes at retrieving hero list, says Diablo 3 retailer is not responding. Has been happening for a while now was working fine before last patch. I don’t have any Razor software etc I have tried everything that I could find. My friends say it comes up that i am online in our clan when i have tried.


#9

Thank you for the info. You mentioned reinstalling/updating Windows. Have you tried to do a full re-install of Diablo III itself as well? In addition to that, please go through the steps to disable the Game DVR, Discord and Twitch before testing again.


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi


#10

I now cannot contact support or reply to the forum where i was speaking to someone. what stupid rule is that where i can only reply 3 times??? This is ridiculous. No one seems to be able to help and now i can’t contact support…

My game crashes on retrieving hero list start up screen says Diablo 3 retailer not responding. I have tried all the steps I could find and were told to do and nothing is working. I have reinstalled the game and scanned and repaired it. I have also updated my gpu drivers and windows fully. I ran the windows memory tool. and i also disabled all background apps like Game DVR, twitch and discord. I have no razor software that would interfere.
I was talking to someone on the a forum who was helping me but for some reason new members cannot reply more than 3 times on the same topic…

their name was Nenyasqi22

pastebin file is
https://pastebin.com/qya91ugZ


#11

That’s because of your forum Trust Level but it’s incredibly easy to get to Trust Level 1, which allows you unlimited replies…

https://us.forums.blizzard.com/en/d3/t/new-forum-guide-syntax-features/72

So, read 5 threads, scroll past 30 posts, and leave your browser on the forums for 10 minutes and you can reply as much as you want.


#12

Hello Sh3lBiNaT0R!

I can see you have tried many things already - thank you for being patient :slight_smile:

Can you please try launching D3 in 32-bit mode, please. You can do this through the Blizzard Desktop Application:

  1. Click Options under the Diablo III logo.
  2. Click Game Settings.
  3. Under the Diablo III entry, you should see an option to use the 32-bit game client.
  4. While there, you can also click the In-game options reset on that same page.
  5. Click Done.

And launch D3!


#13

Hello, after this new patch on 24.09.2019, i played the game all went well last night. In the morning i tried to open it again and this error came: Failed to Launch Diablo 3 Launcher.exe!!! Error 2 “The system cannot find the file specified”. why ? it worked well last night after the patch! I didnt touch anything or alter it in anyways!!!


#14

Solved partialy the problem by using the Bnet exe from partition C, program files x86


#15

Hi HiruZen

If you use the Scan & Repair option in the Blizzard App, that should get things back to normal for you


#16

thanks that worked for me. the game doesn´t update from the diablo iii exe. stupid update protocol


#17

I’ve been having game crashes all day, every game. Scan and repair did nothing, so I changed to bit 32 on the advice above… Worked perfectly ever since.


#18

I just bought this game and i can not even open the game up…
The screen just turns grey and then the error pops up.

Report ID: 87CD4C85-4BBE-4931-843F-F916300E7C0B


#19

Hey, just a wild guess… do you happen to be using either a Razer mouse or keyboard (or both) ?

That report ID can only be used by Blizzard… not sure if someone is up on the forum at this time of the night… They’ll be back in tomorrow morning.

There’s also some troubleshooting you can go through here: