DX12 Fenris error

E 2023.06.02 10:09:35.293998 [Game] pm_dx12::Device::InitTexture: CreateCommittedResource Failed - Error : DeviceLost, SystemCode : 0x887A0001 (DXGI_ERROR_INVALID_CALL)
E 2023.06.02 10:09:35.294021 [Game] [Prism] pmDevice::CreateTexture() () - DeviceLost, Device removed reason : DXGI_ERROR_INVALID_CALL
E 2023.06.02 10:09:35.294030 [Game] [Prism] Device removal detected.

Can`t start game. Gray screen, and Fenris Error. I tried to solve the problem in different ways, reinstalled drivers, turned off texture filtering, added TdrLevel etc. to the registry. nothing helps.

1 Like

Can you create a Dxdiag, upload it to a Texthoster, like Pastebin, and link it here?

For the link you may need to use the option “Preformatted Text” via the Button </>.


The error you’re getting is caused by the game trying to launch the game on the iGPU, which is definitely not supported. Your Laptop does seem to have a dedicated GPU, which however is also below the minimum requirements. It may help to install the current driver for it.

It may also help, to force Diablo IV to launch on it, through Nvidia settings.

no, when the game tries to run on iGPU, it immediately exits with an error, because it does not support DX12. on the second laptop with iGPU, the game works, but regularly crashes with the same error. to force run Diablo IV on it via Nvidia settings 1 I tried - same Fenris momentary error.

You would first need to install the current driver on the laptop you linked the Dxdiag from. If that doesn’t help, then sadly we won’t be able to assist as your GPU is below the minimum requirements.

if it was the GPU, then the game would not run on the iGPU Intel® HD Graphics 620. however, all my game progress is made on this video card. something you have left unfinished in the game, it is still raw.

1 Like

After this mornings Update I am getting this error as well on PC. I can Hardly sustain my anger as the error occurred again while the last boss of the level 70 Capstone dungeon was at 5% HP. This combined with the level 50 Capstone boss vanishing randomly at 5%hp is really making for a Fun experience.

Today after the update - a new error. On the desktop in the window the inscription:
Device removal - head
[Prism] Device removal detected: Error #1.

Hi, I got the fenris error since this morning. I met the same error during the second open beta test.

The game worked very well before the patch of the day (1.0.242176).

Please do something, the game is launching but after 5-10 mn, the game is crashing. I play in hardcore style, it is unplayable.

1 Like

This is insane… 1 day before launch and you guys act like this? People loyal to your game for decades and the only answer provided as a solution is expecting people to trained IT personel for you and provide you with a dialog.txt (from where no one know as no indications are given where to find the info and furthermore, you already know the answer before opening that dialogues… expecting customers to be your IT guides… 199 EUROS for this!!! This is despicable and worth a lawsuit! You developped a game that was used by all kinds of users (iGPU and dGPU users) and have now restricted it to only the ones who can afford a 900$ dedicated GPU + installation if at all possible (if not possible then another 1500$ for a new CPU) you give minimum requirements without mentioning iGPU’s arent supported, take peoples money, and then tell them sorry game won’t work … doesnt meet minimum requirements whenb they do and when your requirements are not clear (and describing two video cards that may meet minimum requirements is not clearly stating the requirements) … not good enough and theft to say the least! Get this sorted please or expect a lawsuit… sincerely, one of your very unhappy customers!

1 Like

Same here. The Game start, I can play 30-40 minutes (maximum), then the crash with Fenris Error.
Graphics Driver are up to date, all Windows Updates installed, …

Can you all please also post the Dxdiag through a Texthoster, like I asked here.

Is this okay?

Same Problem here. My DxDiag

Hi guys, i found a solution for me. I have the razzer app and that chroma s#~~t with my keyboard.

You need to go to Documents\Diablo IV\LocalPrefs.txt
DisableChromaEffects “1” (you will have it on 0, so change the 0 for a 1)
fixed the issue for me.

I hope this help ypu guys!

There is not Fenris error. But “Prism” error - [Prism] Device removal detected. Error #1"

its not this, as i had it on 1 and crashed anyway.

It is so frustrating as i was able to play for 12h with no crashes. Then had one Fenris Error and now i can not even load into a world. Even if i join a game, make a one step and boom . Error . Please Blizz help us :frowning:

Ruffy: I’m seeing lots of LiveKernelEvents with Code 141 for you, which points towards a Graphics Driver issue. I’d first ask you to remove your driver with a program called Display Driver Uninstaller, also known as DDU, and then reinstall your driver.

Before running the program, please redownload the current Nvidia driver.

After having downloaded both, please run the DDU and follow its instructions. After successful driver removal, please restart your PC and then install the recently downloaded new driver.

Hellhound: Same for you, but you’d need the current AMD driver.