[Android phone] Stuck at tavern doors after installing latest patch


#1

Hi,

After installing the latest patch today, I cannot get past the tavern doors on my Android mobile phone. It stays on that screen and eventually will show the sprites error message. In the top right corner, the error code HS:NT304:303:0 is shown.

I have tried the following things already:

  • restarted the phone
  • uninstalled the game, and reinstalled it
  • cleared the cache
  • changed language
  • changed region
  • switching between cellular data and WiFi connection
  • changed my battle.net password

Nothing seems to fix this annoying issue. Weirdest thing is that the game works on my PC and also on my Android tablet, just no longer on my Android phone (Motorola G5 Plus) after updating with the latest patch today.

Please tell me how to fix issue please, since 95% of time I play HS on my mobile phone.

Kind regards

Edit:
I wonder if this issue was originally caused by updating the HS mobile app directly from the Google app store instead of via the HS mobile app first. The update on my wifes Android phone went smoothly and she can enter HS without any issue whatsoever.


#2

I have this problem too. When i’m in front of the tavern’s door the game freezes and then the phone closes the game


#3

I am also stuck at Tavern doors since upgrade…they broke it


#4

Got another update, seems to be fixed now on Android mobile. Hopefully everyone can enter HS normally from now on.


#5

Same issue here, iPhone 7, latest OS, everything up to date, can’t get past login screen…maybe when this will be fixed, the issues with the previous version will be fixed, too (losing connection, doubling/tripling my online friends list, etc).


#6

Good morning,

The assistance we can provide for connection issues on mobile devices is limited. That being said, please check this support article to troubleshoot your issue.


How’s my driving? Let me know! https://www.surveymonkey.com/s/Hagut


#7

Same problem here, every update has a new issue. So disappointing


#8

Same problem here, cant get in


#9

Hi mate,

This is no connection issue.
After the patch (and after uninstalling/reinstalling) every time I open up the HS on the Android it pops up with “initializing” message, and a few seconds later (or a minute) it displays 100% complete. And does not open. Ever. I close, re-click, and here we go again “downloading”.

Cache cleared
Uninstall/Reinstall done

Any advice…? Or a patch to fix the patch? It seems too common an issue.


#10

+1 to the issue.

Edit: +1 to going to android app store first, rather then launching update from HS app.

“We just ran into network problem as we were loading all the cards in your collection. Please realunch Hearthstone to access your collection and resume your duel!”

Or the playful sprites one. And it goes on, and on, and on.

The hilarious part is that I actually received push notification from HS on that very phone saying: “Hey, check out our new content!”
It basically felt like trolling: “Hey, we got new content, but you can’t check it out! Unlucky you, LOL!” :smile:


#11

From other way i insist Mr.blizzard that may y should tell to your paperkids that works for y that may think about the idea that hs will work with graphics that everybody has and it is as it is…STOP upgrade those stupid graphics every single time and let people play a damn card game and enjoy it as it is on everyone’s device…Those blizzard papaerworkkids that will attent to reply to ME…i have the answer right away… .!.


#12

Exactly the same problem here.

Edit : The game worked fine while it was downloading the last part “in game”, and then afther the full download it started to do the initializing thing as described by cronomancer.

So i would think it’s not a connection issue, but a problem wit the patch because the “unpatched” version worked fine 5 min before.


#13

Blizzard close the doors to the pass through phones so all we must log from pc and see news for new expansion and new money priZes for pre purchase etc…kkkk blizard we saw it…pls let us play from android loool…


#14

So what are you going to do now? Clearly an issue your end…does this get passed to level 2. So the geeks at Blizzard can actually fix the thing? Be nice to actually get an answer from you people


#15

Same problem for me with Android
I had to make a new install because new cards texture were not displayed in game, and I am stuck in the loading screen since that.
I’ve made a complete reinstall, deleted cache and storage, checked permissions…
My phone is Honor 7 with Android 6.0


#16

Vyzkoušel jsem všechny postupy a problém pořád stejný.Telefon Lenovo P1 Vibe.Po aktualizaci pořád jen dveře taverny a hra neodpovídá.Jen 2x se mi podařilo dostat do hry po úplném smazání a instalaci znovu.Přece nebudu pokaždé dělat novou instalaci,abych mohl hrát a to není vždy zaručené.Navíc se ve hře vyskytují bugy v podobě chybějících karet.Platím si bundly a nemůžu hrát.Opravte to a dejte hráčům zpětnou vazbu, že je problém po aktualizaci na androidu, protože jak vidím postižených je nás čím dál víc.


#17

Same here with IOS, stuck at tavern doors for another day now. Though no error codes or anything pop up.


#18

I had the same problem on my Android phone, from yesterday to today, but a few hours ago I uninstalled the game and reinstalled it, and then it started working, and keeps working fine.


#19

Co máš za typ telefonu?


#20

Having the same issue, I can ckear cache and data redownload the update an itll work play few games then cut app off an when try get back in stuck at tavern doors. I dont have 10 to 15 mins to redo the update everytime i want an can play a game. Something is still bugged or broken.