Can't log in on mobile android

Cannot log into Hearthstone on my mobile app.

Tried absolutely everything.
Updated everything.
Restarted and reinstalled everything.
Changed passwords.
WiFi and mobile data.
Etc etc etc.
Just spins round and round and doesn’t log in

1 Like

Hello Mithrandir,

Thanks for the details. In order to try solving this, please try the following :

  1. Delete the game data+cache before reinstalling it
  2. “Log out from all devices” from your account management
  3. Change your password
  4. Relaunch the game

If enabled, disabling the IPV6 can help sometimes.

Did all these, still not logging in.


I have the same problem

I can log in my battle net account but i can not login the game

Game ask me sign in over and over.

What can i do ?

1 Like

Same problem here. It keeps asking me to sign in, endless loop.

No solution?

Hello .
Damn, but I’m rewriting this letter for the second time, and it irritates me terribly, but all the same, I’m interested in understanding what the problem is.

I can’t login to Hearthstone. I can’t log in at all.
The problem is that after I enter the game, the prompt asks me if I want: “Sign in” or “I am new”

After that, I provide access to my Google storage.
Next, I am thrown into the browser where I have to log into my Battle net account.
I log into my account and then it shows me my personal account in the browser, there you can switch something to change, that is, everything is fine with the account, you can even see that it is active (although, in theory, I should automatically be transferred to Hearthstone).
Next, I restart the game after which it restarts and again shows me the “Sign in” or “I am new” prompt. Next, I click Sign in again and again I am transferred to the browser, where I log in to my account again AND HERE THE MOST INTERESTING BEGINS. After the second login, I am thrown into the game, the game restarts and again shows the INVITATION “Sign in” or “I am new”.
After numerous manipulations:

  • Reset your account password
  • Turn off Wifi
  • Forget Wifi connection and reconnect
  • Clear game cache
  • Clear the game data (by the way, then you have to download all the data again, but that’s okay =)
  • Force stop the game
  • Reinstall the game
  • Unblock account

Nothing helped … I myself work in the field of technical support, so I understand how difficult it is for you to work, I try to describe the situation as much as possible.

I have a phone, a fairly new Xiaomi Redmi Note 11 and I have previously installed Hearthstone on it and everything worked perfectly. After uninstalling and reinstalling, things didn’t go according to plan.

If it helps then my Battle Tag is in the game
My account is linked to a mailbox

Thank you for your reply. I will not stop trying to fix the mistake)

Now I’ll try how it works after resetting the mobile phone to factory settings …

By the way, perhaps the problem lies in the fact that it is possible to connect via IPv6.

Last time I downloaded HS in another place, and I know for sure that IPv6 support is disabled on the router.

Hmmm… I think problem is in some data of HS .
Maybe this some troubles with google account , after reinstalling HS on my phone .
NOW I AM HERE, and can finally play in favorite game x)

That’s awesome man ! But there is a reeeaaaallllyyy big problem. I have 30 gb data on my phone and I can’t transfer the data into a pc ('cause of some other issues) . So I can’t do this method. But maybe this IPv6 thing works. :thinking: :thinking: :thinking:

1 Like

Ever get a fox? I’m doing the same thing on my Nvidia shield tablet

Wow an issue that is years old and there is still no fix for it up to this day.

You can still not login via the app

1 Like

It’s amazing how long this problem has been around. I installed the game yesterday and got so frustrated trying to sign up that finally I decide to uninstall and accept that I can not be able to play with my account again.
I tried everything, delete data, reinstall, sign in with Google, Facebook, battlenet user and password, and nothing works… (also, “default phone reset” can’t be a solution, people don’t just use their phones to play Hearthstone) after any attempt it shows you the “loading door image” and ask you again if you are new to the game or if you want to log in.
We need a solution, some alternative way to log in, or ideally the mistake fix!

Folks, listen up! I’ve been having the same issue for several days but, someone’s review on play store helped me sort it out so, credits to that guy. Anyway, just log in to and click on connections located in the left tab bar, link your google account with it, then open hearthstone, click on sign in but select the log in option with the google icon this time and type in your credentials which should get you right in, you’re welcome!

1 Like

So this is still a problem as of May 2023.

New tablet and first time opening Hearthstone and it just loops and doesn’t log you in.

How I fixed it was clear the cache of Hearthstone. Open your default browser, log in and confirm any MFA challenges, I didn’t get this when the game promted for log in.

Once I had successfully logged in via the default browser I then opened Hearthstone and yes… It prompted to log in again but it worked this time.

No doubt no Blizzard devs read these forums but if you do please have a look at the auth during log in and how it hands off to the game.

This worked for me! Thanks

Solution: Completely close the game, open your web browser, login on the website, go to your settings, connections, connect your Google account. Now open the game, go to the login, and click on the Google icon to login with Google account. It will find your account and you chose to continue with it.

NOTE: This didn’t work first few tries for me but then suddenly worked on third try so just try it few times.

ALSO: Make sure your phone isn’t in battery saving mode because it prevents apps communicating with each other and the login cannot pass information to the game.

1 Like

I’ve found out that for me it was just logging in through the app webview (the browser integrated to the HS app) that wasn’t working. So when on the login page, I just clicked on the top right button, clicked on something like “Open In My Browser”, logged in in from there, and tadaaaaaa

1 Like

I downloaded the game with self net data…TWICE…I have to pay a lot for that…otherwise when I used wi-fi it said connection lost. If i play on my mobile data I can play but as soon as i turn wi-fi on…instantly loses connection. Reinstalled / patched several times with mobile data…I connected my phone to a computer to be able to delete cache folder…it says it cannot be deleted…so what can I do? will blizz pay my mobile bill? Still can’t play and I won’t waste my mobile data any longer…

Here is another similar solution as none of the above user advices “directly” solved my issue.

  • Open the game and skip the login part.
  • In the options, click login.
  • A new window will appear where you will be asked for username and password. WE NEED THE LINK to that window. Trying to open it in your browser may not help. So we want the link to use later. If you can copy the link, do it. I couldn’t, so I saved the link as a bookmark.
  • Open your browser and login (do not paste the link yet).
  • After you login, paste the link and follow the instructions (if any).

  • The problem is you cannot login to then redirect to game. Remember this and try your way if this doesn’t work for you. In my solution, I made sure I was logged in before pasting the link. If I login, then go to game and let it direct me, every time a new tab/window opens, it logs me out from previos session and doesn’t redirect correctly. For this, you need to SAVE/COPY THE LINK the game creates for you and GO TO THAT LINK AFTER you login from your browser.

I can confirm that this worked on my Samsung tablet.

After installing HS, I was asked if I wanted to log in with an existing account, or “Not now”. I pressed “Sign in”, and was taken to the login form in the built-in WebView browser. I logged in and was sent back to the game, but was presented with the “Sign in” or “Not now” dialog. This would happen in an endless loop.

The fix:
When taken to the login form in the WebView, press the 3 dots in the upper right corner and open the page in your favorite browser (I used Samsung Internet, lol). Then log in as usual, and this time you are redirected back to the game, with a successful login!

Thank you so much for this solution, Pull!