Hearthstone Android

I have the same issue. It has never been a issue in the past. The issue in on blizzards side. Throwing out troubleshooting that doesn’t work in anyway won’t fix the problem when the problem is with them. Extremely frustrating

Also i have logged in and linked my google and Facebook for what its worth. Tried logging in again. Same issue. The page loading bar just starts to run then resets as if you never pressed the Facebook or Google login icons. Neither does you password work. The page just loads and thats about it.

Alot of people are being pissed off right now. You guys have been able to fix the worst technical issues in the past but this log in issue/bug has you by the balls.

And its been a while sitting with this issue yet nothing is being done. Banana republic. Sad but true.

And by that way ,points of goals or golds we don’t win because we can’t login they will not be giving us back , that is too annoying.

1 Like

If this was world of warcraft it would have been fixed by now.

Log in screen is looping even I enter my password and approve on auth. Really? Will this problem be fixed soon?

That do nearly 2 month we are saying the game don’t login

Changing from mi browser to Google chrome as a main browser worked for me

For that can’t play i’m on a new phone and the game will not work on phone under 6Go Ram, and that is really annoying because the game working without problem on my old old phone 2Go of Ram.

Very bad idea Blizzard for doing that in.

When will you solve this problem, blizzard?! It’s been over 2 months!!!

Still same… And same problem for Diablo Immortal… Google and Facebook solutions not working anymore… I really hated this… Please solve it however u do this.

since introduction of Mercenaries, game is becoming harder and harder to play on Android after each major update
I use Samsung J5
for last week or more, game is almost unplayable

  1. loading game takes much more time (3x more time at least, than before)
  2. choosing game modes takes longer
  3. I had issues with Merc or BG before, later, merc had menu errors, while BG had connection errors, now BG, Merc, Ranked have same issue
  4. I choose mode, push play. I hear sound that game connected, but in most cases blackened bar appears on screen 0% written on it. and game crashes and tells me “click anywhere to reconnect”
  5. before it worked, now it does not work. when I do it, game tries reconnect, but says failed, and requests I restart game
  6. in cases, when game reconnects, I do not see my portrait, enemy name, my or enemy decks and cards and can not do anything but click “finish” button. after it I am unable to do anything but surrender

and this is awful

I connected support, did whatever ticked said

change mobile/wifi internet, uninstall and reinstall game, clear cache/clear data, etc
problem is same
and I see many people having same problem without solution

1 Like

Still the same problem plz blizzard

I’ve been having the same problem for a week. I just tried a different browser, nothing changed. Blizzard, when will you find a solution, I’ve been playing for 6 years, this is the first time I’ve encountered something like this.

The problem is the same as in this video, please find a solution now.

Clear all Hs data, uninstall hs, restart phone… download and install hearthstone again (main app size ±160 MB) then open HS it will start updating (±2,9 GB). after updating, a login screen will appear => close app and open again. HS it will start updating again, but you must stop it. (no paused, no close app, but STOP!!!). now you can reopen HS and normaly login via login screen/browser.

I’m having the same issue on a new phone. Hearthstone opens some clunky browser window instead of the way it used to work like a year ago when I last used the app.

I can kind of log in if I proceed to type in the account info but it opens the US website so (unsurprisingly) it logs me into the wrong region. There doesn’t seem to be any option to change the region on the login website or within the app. Also the only way to log out is to reinstall Hearthstone.

[edit] Actually the region seems to be tied to system language. But there really should be a way to choose a different region without messing with Android settings.

[edit 2] Of course simply changing your system language back to English would be too easy to prompt the app to change languages properly. If you do it without first switching to English in-app, you get amazing new game modes such as GLUE TOURNAMENT and GLUE ADVENTURE. :wink:

Hi there; problem just solved (but dunno if it was luck)
I changed my phone to android and have same problem. When trying to log in, if i confirm from authenticator directly, hs has error on screen “blizzard-hearthstone:localhost:0/?ST …keeps going on like this”, if i try security code manuely it keeps looping. Cleared cache, re-installed the game, tried to log in with facebook/google/apple account nothing changed.
When i tried to log in with google account, on log in screen i clicked on 3 buttons and choose to open page in chrome browser. On authenticator i choose security code manuely it logged in?!?