Game not launching after Nvdia driver update

Please help. Thanks!


i have the same problem here! endless loading bar. Is the update for nvidia? i dont know!


so? what we do? we are the only 2 persons with this problem! and i just came back after 4 years to play the game! damn it!

1 Like

Maybe the servers are in meintenance mode

i have the same problem here, but after wait 5 minutes games is launching

1 Like

There is a workaround:
Open starcraft, then wait for the loading bar. Now open command line and paste this:

ipconfig /release & ping -n 2 & ipconfig /renew

Then the bar should disappear and there you go.

Credit goes to:


Thank you for your help. I did the things you suggeststed and nothing changed…

It’s ok, maybe I wasnt clear. Open sc2 wait for the loading bar. Once you got the bar then open CMD and paste. Loading bar will dissapear and you enter the game.
Unfortunately you need to do this each time you open the game … but maybe, there is a smart person here who knows scripts and can generate us a batch file that will do this automatically.
All of this is until Blizzard is going to patch it.
From what I read, it works for some (including me), and for others does not.

1 Like

works for me! miracle! thx

Thank you so much, it did work for me!
Anyways i didnt updated anything and got this issue.

Create a new text document (.txt) copy paste the command, then Ctrl+Shift+S, type the name and write after it .bat, for example: sc2launch.bat
There is your bat file, enjoy!!

Yes, it works, thank you!

Same problem here. Finally launches after 7 minutes of waiting. :poop:

1 Like

Note the suggested fix does not work if you have a static ip (if you don’t know what static ip is you probably don’t have one). Alternative way to do it is (while the loading bar is showing):

  1. disable, enable network interface
  2. unplug the lan cable, replug in few seconds
  3. turn off wify (if you are on wify) and turn it on again
1 Like

thank u, the solution did work. I got into the game but when i enter the command the loading bar closes and starcraft opens but it also disconnects my battle net from internet and now am left in the game with no connection to the battle net and it wont work without battle net. Does anyone have a solution to the disc. problem?

Try this (scroll down to the bottom of the post, there’s a tl;dr): [Main Thread] Game not loading after clicking Play - #167 by Talv-2620 - Technical Support - SC2 Forums

I used the files he attached and the issue is completely solved. I don’t need to disconnect my internet or do the /release /renew thing anymore.

1 Like

God flipping bless MVPs like you. It worked with no more issues, now i can finally go back to hating protos

Just updated to the latest Nvidia drivers (466.11). Problem is gone.
UPDATE: Problem reappeared after couple of days.

This issue is still happening and the fix still works. Nice one!