Classic Era Transfer Problem


I’ve been trying to use free transfer from Flamelash to Firemaw on classic era realms
but it doesn’t let me do that, in free transfer option after I chose a character “the continue button” is gray (no response)
I want to transfer all my characters from Flamelash to Firemaw
as you can see from this pined post

It’s still available, I appreciate your help.

1 Like

That thread is from over a year ago so I very much doubt the free transfers are still open. A couple of months ago they were giving free transfers off Firemaw because it was too full.

This is for Era, not Wrath. They closed free transfers on Era, when they closed the SoM to Era transfers due to a bug (one or two weeks ago, I think). Free transfers were open before that. There hasn’t been any communicatuon about this, as far as I know. They never said they closed them and never said if/when they are planning to reopen them.

True I’m talking about classic era transfer, it was working recently and stopped now, although the free transfer option still exist on all era PVP clusters except for Firemaw cluster, but still not working I tried a minute ago

1 Like

That was shut down as it didn’t work properly.

1 Like