Covenant introduction not progressing, cannot gain renown, cannot progress, cannot get soulbinds. It boils down to that my character is locked out of this expansion

I Switched Covenant from Night Fae to Necrolords.

At the start of the campaign where you are given your powers, the quest “Power of the Primus” appears on my map, but the NPC is not there.
Now I cannot continue as my character cannot get his soulbinds, cannot earn renown, cannot get any dailies and cannot progress in the Campaign.

I have submitted a ticket, (EU76483187) but the reply was to please sumbit a bug report. I have, but simply cannot accept that I have been locked uit of a large feature of the expansion on my main character.

I have had GM’s reset quests for me in the past, why can this not be done now?
Can you please solve this issue.
Thanks in advace!

1 Like

I had the same kind of problem after switch covenant on a toon with thread of fate.
I was locked at renown 2 or 3 because I needed to unlock a companion that’s obtained through a serie of quests but either not story related or forgotten in the thread of fate because it’s covenant related.

I advise you to check all quest in maldraxxus that can be related to your first soulbind (it was the case for me)

1 Like

Thanks for the tip, I’ve scoured the entire map top to bottom to see if anytthing was left, all was done, all bonus objectives, sidequests, heck even the dailies just to be sure.

The problem I Think what happened is the game skipped the quest to give me my covenant ability (power of the Primus) the whole thing got stuck after I got fleshcraft.

I already got my abilities when I switched covenant but somehow the quests to give them to me were still in. now the questionmark on my map is in the middle of the room, but Draka is already on the higher pedistal, but does not give the quest.

It is visible on the minimap and Large map though :(.

1 Like

I have the exact same problem… been like this for two days


I have the same problem on Venthyr, Stuck on not getting the next quest A calling in Service. Also made a ticket EU76497466.

Think it is general bugged.

Same here going mad !

apprantly we’re not the only ones, and theres a hotfix pending but no word on release.

Issue was solved by a GM for me, hope all you others get fixed soon, thanks Bliz!

Had the same thing with necro. Went back and things just worked themselves out randomly. Drakka was standing in the middle and asked me to test my spells, and everything just went smooth after.