Cursor jumping to the middle of the screen when clicking

So i just came back into wow with the 8.3 patch, but i am having a weird cursor problem

ever so often my cursor will jump too the middle of my screen turning my camera in the process.

I tried a few of the fixed i could google but non of them have worked so far

fixes i tried so far:

" Mouse jumping/centering FIX" everything on this list

/console rawMouseEnable 1 (this fixes the mouse jumping to the middle but now it just goes to the sides instead)

adding: SET gxCursor “0” to the config file

1 Like

I’ve had this problem in the past when the Discord overlay is enabled - from talking to friends this can also be caused by other overlays. So if you have the overlay enabled try disabling it and restarting WoW.

all overlays are disabled :frowning:

i have exactly the same problem. and it’s driving me nuts. i’ve tried all the “solutions” that people provided me with from google and even US wow forums… and all blizzard is saying is that it might be on my end! Addon problems… broken mouse etc… but that’s all BS

i think it happened after patch 8.3 went live.

but the strange thing is… i’m now also having this issue with wow Classic

Overlays are a good call, as this kind of mouse snapping does tend to be down to software interference. One thing that’d be worth checking is if it happens when you literally only have your Operating System and the Game running.

You can follow this guide to restart your system in a way where only the Operating System gets loaded - https://eu.battle.net/support/en/article/23848

Thank you galcavon

it turned out to be corsair icue that was the problem. Closing all services from corsair fixed the problem :slight_smile:

1 Like

Thank you galcavon it turned out to be corsair icue that was the problem. Closing all services from corsair fixed the problem :slight_smile:

Nexzér You actually just saved my life, i have tried every single thing i’ve seen people mention and nothing worked. I come here and i read that it turned out to be something Corsair related, and i go and close all Icue / corsair exe’s in the taskmanager and there it was. FINALLY fixed, after i don’t even know how long. You sir are a literal god, THANK YOU seriously for posting how you fixed it. I seriously cannot thank you enough.

Have a really nice day everyone that might pass by here, this post above fixed my long suffering once and for all!.

I think its helpful to add this. I play multiple private servers of older wow expansions and this mouse jumping to middle of screen happens on every single client just not retail for some reason. I have iCUE for corsair, closing all corsair services and typing /console rawMouseEnable 1 with a combo of lowering mouse polling rate to 125 or lower seems to have “fixed” the problem. It still happens every now and then but its 900 times less frequent. I basically cannot seem to remove the problem entirely sadly. I also tried with 3 different mouses: Logitech, Razer and Corsair. Same happens to every mouse I test with.