Mouse jumping/centering FIX

Hi guys

I have had an issue with my mouse for a very very long time, more specifically, since MoP… The issue were a WoW related issue, meaning I wasnt experiencing this in any other game. My mouse would either accelerate like a dog sniffing a goodie or else it would center my mouse… Very annoying

I have now invested a small childs lifetime of research on how to fix this issue and I am guessing many of you guys are struggling with this issue till this day, as it is more popular than first anticipated.

Do not lose hope boys, I have found that theres no 1 solution, I tried 8 different solutions that worked for alot of people, but for me there was only 1 solution.

PS: Many of these are copy pastas.

Fix 1:
In wow, u open your chatbox and type this in.
/dump GetCVar(“rawMouseEnable”)

If you get the [1]=“0” then put this command into the chatbox:
/console rawMouseEnable 1

This fixed my issue.

Here are a few more commands to play around with:
/console rawMouseEnable 0
/console rawMouseAccelerationEnable 1
/console rawMouseRate 125
/console rawMouseResolution 400

Fix2:
Disable any overlay you have over WoW, such as Discord, PlaysTV etc.

Fix3:
Disable/Enable Hardware acceleration inside the battlenet APP
On Battlenet App under “Options” Go to Game Settings; General - scroll down then check that Hardware Acceleration is enabled.

Fix 4:

  1. Open the World of Warcraft folder.
  2. Right click on Wow -64.exe and select Properties.
  3. Click the Compatibility tab.
  4. Check the box for “Disable display scaling on high DPI settings.”
  5. Click Apply and then Okay.
    (This is mainly a fix towards random mouse acceleration issues)

Fix5:
Go to start
Search for the Control Panel
Search for Change mouse settings
Open the Pointer Options tab
Uncheck Enhance Pointer Precision

Fix6:
Any hardware that might wanna share control of your mouse may cause the problem (such as tablets, dual PC setup etc.)
Unplug/disable software related to it, check if the problem persist.

Fix7:
Addons, disable them all to see if the problem persist.

Fix8:

  1. Right click anywhere on the desktop and select Screen Resolution
  2. Click on Make text and other items larger or smaller
  3. Change the size of text to Smaller - 100% (default)
  4. Apply, click on Log off now and restart

Fix9:
Lower Polling rate of your mouse to 125 or lower.

Fix10:
Disable razer synapse to see if the problem persist.

Fix11:
Open task manager
Right click WoW. exe
Set affinity
Only select 1 core.

Fix12:
Quote from “Amount”
“I had to format my hard drive and reloaded my OS (Windows 7) and the mouse going to the center of the screen has STOPPED!
My DPI is set to MAX now.
Just figured I would add some info.”

Fix13:
Disable Vertical Sync
Try going into window mode or fullscreen.

Fix14:
Reinstall your game

Fix15:
Reinstall drivers for mouse.

Hope this helped.

21 Likes

This worked great, thank you so much!

Due to this being an old thread I am closing the topic, but the information will remain. We do also have a few mouse troubleshooting guides on our Support page with a lot of this information too.