Eye beam stutter/hitching

Hi, as the title states there is something wrong with Eye beam. Almost every time I activate it the game hitches/stutters real quick and then goes back to working flawlessly. It seems to only happen when you’re NOT already in Metamorphosis, meaning that it seems to only happen when you trigger Metamorphosis via the Demonic talent through the use of Eye beam. I would not call it lag or an extended framerate drop. More like a hitch or quick stutter. First I thought it was addon related so I reset my entire UI, scanned and repaired the game files and ran the reset cvar_default command in game. No luck. It still happens.

To give some context to the issue it sort of similar to the ongoing bug with hunters call/summon pet where the game also hitches/stutters a big when you summon pets. If you can’t notice this then you’re framerate is irregular or bad already. The issue relating to hunter pets can be found in threads and reddit posts since it seems to be an issue that creeps up from time to time.

In any case. My guess is that it’s not actually Eye beam itself but the gain of Meta through Eye beam that causes it.

Now for what I’ve tried on my end to fix it:

  1. I’ve updated to the latest nvidia driver (546.17 as of this post)
  2. I’ve tried to enable or disable HAGS
  3. I’ve made sure nothing else on the system is occupying resources
  4. Made sure to fully reset shadercache and similar
  5. Fully reset the UI including all the cvars that for some reason get saved on Blizzards end

Nvidia GTX 1080ti
i7 6700K clocked and locked at 4.6ghz
16gb RAM running in XMP
1200w PSU (overkill for the system but the only one I had on hand)
Windows 10 pro installed on an SSD
World of warcraft installed on an SSD

Nvidia GTX 4080
i7 13700k running locked stock clocks. Meaning the clocks to go up or down depending on load
32gb RAM running in XMP
1200w PSU
windows 10 pro installed on an SSD (stripped down os with only around 40-43 processes on boot. DPC latency optimized rig)
World of warcraft on an M.2 SSD

The issue can be observed on both rigs to pretty much the same degree. It is very noticable for since I’m playing the game on a 360hz display and generally get quite good fps. If anyone has any idea what is going on or if they experience similar issues please let me know.

I would also like to add that I think this is a sperate issue from the one reported on the DH discord where you could fix/mitigate it by disabling Elv ui combat text or whatever. Again, this one feels more similar to the aura bug like the one with the hunter pets.

Just did some more googling and here is an old post reporting a similar issue. Both of the lads in this post mention the same type of thing for both druid shifting and summoning hunter pets

Another old reddit post from a hunter on his Steamdeck. He seems to think that there is something wrong with his Steamdeck but in reality this happens on all systems

Here is another one from Eiwo high-end player currently in MNM if I recall who posted about a similar issue back in 2018 regarding hunter pets and when stat buffs/auras get applied to your character. As you can see people still refresh this post until this day.

These are just a few examples. There are countless threads out there about similar issues. Some might not phrase it the same or even call it stutter. However what a lot of these threads are talking about is not general performance. They’re talking about these stutters hitches attached to specific spells. Often spells that transform your character. Like druid shifts or meta for DH. Another interesting thing to add about hunter pets causing a hitch when they’re summoned is that summoning your mirrors with Storm, Earth and Fire or Xuen on a Windwalker Monk has the same effect. Probably because these are also pets in some sence.

Okay, so I just also want to add that I want this game to be the best it can be but having a poor performing product sucks att the enjoyment out of it. I know the game has gone through a lot of updates and that the foundation of the game is old. But we didn’t have combat issues like this back in Legion, heck not even in BFA. I’m willing to accept that there is something wrong with my setup that I can fix to make the game work but this radio silence or just random links telling me to reset my UI just makes me very tired. Give me something of value, something concrete. I’m willing to provide dxdiag logs or anything needed if you still think it’s on my end.

Another edit:
Watching Avade from Liquid progressing Fyrakk Mythic tonight on his stream over at https://www.twitch.tv/zevade
The Eye beam stutter clearly visible on stream even tho the stream is only 60fps. Didn’t add any timestamps but it happens very often when he does Eye beam without being Meta already. So in other words, when the Eye beam is triggering Meta through Demonic

The curse of the griefer.

1 Like

I don’t even know what that means, but okay.

Fel devastation which is basically the same thing as Eye beam but for Vengeance which also triggers the vengeance version of meta works perfectly fine. It’s just Havoc Eye beam.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.