Game doesn't work after 8.1 patch

I am only just realizing your username.

You wouldn’t by any chance have an account on resetera ? lol!

Hello? Can You say something after 5 days?

1 Like

Hello? Can You say something after 6 days???

@Iszer,

Thank you for the provided diagnostics, unfortunately this does show that your system does not meet the minimum system requirements.

I would still suggest to close background applications as much as possible, and update your system drivers and Windows updates as much as you can and see if that helps out. We will not be able to troubleshoot this further though, as your system does not meet the minimum system requirements.


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi

@Aeiya,

Thank you for the diagnostics as well. Your dedicated graphics card is not showing up correctly in your Dxdiag. I would suggest you go through the steps to first uninstall your current drivers thoroughly using a Display Driver Uninstaller, and installing the latest drivers afterwards (both for your Dedicated AMD Radeon ™ R5 M330 and Integrated Intel® HD Graphics 5500).

Once done, double check your power settings to ensure it is set to High Performance and test World of Warcraft again without TeamViewer/Twitch active in the background.


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi

Evening. How do I include my msinfo and dxdiag files in a comment ?

Also, why am I only able to comment on this entire post by replying to other peoples comments…I can’t make my own reply !? Strange.

Thank you for your reply. As I said before in this topic I have already reinstalled drivers for my graphic card to the newest ones. But ok, can do it once more. Also I have set everything in Power Settings to the Highest Performance. I will shut down every useless process in Task Manager and will check if that would help, but honestly I don’t think so :slight_smile:

I had the exact same issues with amd graphics card and i fixed it by a method which many people dont know about.

1:Uninstall your graphics card driver using amd removal tool from their website.
2:install the previous version of amd graphics card driver one from may 21 2017 version that one works for wow.
3:Why do AMD drivers never work for Blizzard games is a mystery to me seems like you guys hate AMD tech or something :joy:.

When i installed AMD adrenaline 19.1.1 the game run properly(my system does not meet the minimum system requirements :slight_smile: ), but after few days when starting WoW i got a blue screen. The blue screen appeared only with WoW, the rest of my games worked good.

1 Like

Again I am sorry to keep making new comments replying to you, but I can’t select the REPLY button at the bottom, only the reply button on other peoples comments…and it’s only this one thread it seems to be happening on… clears throat

MSinfo32 - ttps://pastebin.com/sU50z2y8

DxDiag - ttps://pa.stebin.com/zXYvR630

Tell us again how the problem is outdated specs, after reading that, and I can confirm there is something else going at Blizz HQ. I am genuinely starting to getting p***sed off with the way you people are treating the players. Fobbed off at every chance with the good ol “doesn’t meet required specs”. Try again.

Btw those links are missing an H at the start so I could post them.

@Hawkh:
Don’t worry about replying to my posts, that’s fine. :slight_smile: The “cannot click reply button” is a known issue that is being worked on, it’s something that I encounter very often myself as well (not only on this thread, but most threads for me actually).

Let me start by thanking you for the diagnostics. Unfortunately I can confirm that your system does not meet the minimum system requirements either. As I mentioned earlier in this thread, we can still suggest some things to go through (such as trying new driver updates for your hardware, reducing background applications and such), but ultimately cannot promise that the game will run on your system.


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi

lol scroll up and actually read my other replies mate, the game works perfectly for me.

I gave you those diagnostics to see if there is maybe some driver or update that my “outdated” system has that all these other top end users don’t.

Honestly go back up the post and read my replies as you seem to have not read my older ones in the slightest.

1 Like

still nothing lol this need to be a joke i still play game on intel hd …

The irony of having “out dated gpu” and still able to run the game at 50+ fps all the time.

Even tho Intel HD 3000 / 4000 not supported anymore, alot of laptops are running double cards and some of them still supported. Game just don’t recognize them since 8.1

AMD Radeon HD 7610M for example still on supported list.

3 Likes

Black desert online? -working. TES online? -working. Guild wars 2? -working. Tera online? -working. World of Warcraft: Beta for Azeroth 8.1? - Thank you for the provided diagnostics, unfortunately this does show that your system does not meet the minimum system requirements.

Oh my they actually fixed it.

6 Likes

^^^ I can confirm this.

WoW is finally working on my AMD Radeon HD 8870m GPU after an update. Thank you, Blizzard!!!

2 Likes

HD 8750m as well. And for some reason it works better than a day ago.
Thank you, Blizzard.

Working. Thanks Blizz.

Can confirm, after the latest patch Game Client opens without any problems.
@Nenyasqi, could you specify what was the problem here?

1 Like