Game doesn't work after 8.1 patch


#312

im certainly 95% sure…i Uninstalled all actualization comming from 12.12…even if one actualization pop up again it is in places where sun never shines


#313

Well, the old saying says “The one that says something cannot be done, should not interrupt the person doing it.”

Though that patch would be hard to keep off indefinitely, will be part of any future security rollup. Not exactly advised to remove it.


#314

man gotta do what man does O_O


#315

my man watches F :wink:


#316

So lads the lame fix for the time being is to open your power settings (i play on a Laptop), and then set launcher and wow to power saver. The game runs off my intel chip and looks like garbage, but if you turn everything to the very lowest, it almost feels like 30fps in a busy BG, which is good enough for me to experience 8.1


#317

Just as a little summary and for clarification:

There are two major problems decribed in this post:

  • DX12 not working (fix/workaround ist to switch to DX11 in the config)
  • Wow showing a white screen on starting, especially on Notebooks with switchable graphics (primarily AMD gpu’s)

The latter ist not yet solved. There is a workaround to put the Wow.exe settings to energy saving in the graphics control center (e.g. ‘Catalyst’ for AMD). The game loads with the processor gpu (Intel HD XXXX) and thus with lowest possible graphics/low framerate.
There is no real fix, as the problem is most likely not caused by the computer/user. Even updating to the latest drivers does not work. Neither does it have something to do with minimum game requirements, as also supported graphics cards are supposedly affected.

We will need to wait for a fix by Blizzard Entertainment before we can play the game again with good graphics on our dedicated gpu (e.g. AMD mobile gpu).

@Blizzard Community Managers:
Please give us some feedback on if the issue is being worked on by your bugfixers/tech specialists. Maybe on Monday, as there might be no information from the relevant department on the weekend.

Thanks in advance.

Rgds,
Jheruun


#318

I reinstalled Win 7, did not install updates, but it did not help. Game developers broke it down securely.


#319

I found the opposite to work - same path, but select ‘high performance GPU’ in Control Panel(s) for Nvidia/AMD, and ‘Maximum Performance’ in advanced power options for graphics (this was on a friend’s Dell Inspiron, with Intel basic/Radeon dedicated)

But yes, it’s the game, not the hardware that’s at fault.


#320

To summarize and highlight. The issue with black/white screen while using SUPPORTED amd graphic cards has not been resolved yet.
Basically, the game does not see our dedicated graphic cards.

Blizzard needs to find a solution or contact AMD for them to do so ASAP! Right now we are losing our game time because of their poorly implemented patch.


#321

I downloaded the latest drivers for my GPU.
I am using a GTX 1080 so I doubt my GPU is too old?
I am experiencing issues too as a Nvidia person.
The game just locks up and crashes after booting up wow.
I redownloaded WoW already and tried running scan and repair but nothing works.
Are there some fixes that work or is the game just broken?

Edit:
I’ve been stuck on this for 2 days already and I’m losing gametime! Come on blizzard.


#322

@Elah:
Can you post screenshots from the exact settings and where to find them?
Either it did not work for me (Dell Vostro, Intel/dedicated AMD gpu) or I did not change the right settings.

Cheers!


#323

@Elah:
In the ‘advanced power options’ I have two options for ‘Switchable dynamic graphics’ showing up.

On one I can select ‘Maximum performance’, with the additional options:

  • Maximumperformance
  • Optimized performance
  • Optimized energy savings
  • Force energy-saving graphics

On the other, I can only choose between:

  • @%SystemRoot%\system32\atimuixxx.dll,-114,Automatic GPU selection
  • @%SystemRoot%\system32\atimuixxx.dll,-114,Force power-saving GPU

Maybe it has something to do with this?
Maybe the game cant determin which gpu to use?
(Windows 7)

Cheers!


#324

Come om Blizzard i am on aaMD Radeon HD 6900M on my old Alienware a new card on that laptop is not the answer i have played wow for many many years and diablo too, you always F… up on your updates please fix this before chrismas evening ore you will lose my money and I am not the only one. Please Advise.


#325

Yea still no Bluepost-Reply yet regarding this topic…
Would be at least nice to hear if they are looking for a fix or not. :frowning:


#326

For me the game is running but i have to wait 15 minutes for it to launch without doing anything on my computer or it would crash…


#327

Thanks, I’m gonna try that now…

We were suspecting here as well that the game can’t decide which gpu to use and thus crashes. Maybe it needs time to figure it out? :stuck_out_tongue:

Nevertheless, this needs to be fixed!

EDIT:
For me it also seems to load after ~10 minutes on the dedicated gpu.
When I try to access the system settings, it crashes again.


#328

fuc.king blizzard and their fuc.king bullsh.it sh.itpatching, so pissed


#329

Your lucky my wow just crashed and now apparently Battle net can’t find the wow executable and is only showing “Install” … wtf is that all about it was playing fine 10 minutes ago…


#330

Let’s see if we get at least some information tomorrow when it’s Monday and people are in the office again :wink:


#331

Sup party people,
Whoa, 3,5k views and we still didn’t get any attention?

So, guys, I’m planning to try something out and the reason of sharing this before starting it is that it is possible, that I can’t do it. It depends on how that computer is doing. But if some of you – the more is the better- could try this out the better it would be.

If you have some other older computer at home (or if you can borrow one), pc, laptop, doesn’t matter, someting what you don’t use anymore just didn’t sold/threw out yet, try to install WOW and try it out. And don’t do any uppdates, Windows, drivers, nothing. Just try it out in an out-of-date-oldie-mode. See what happens. I’m planning to assemble ol’ Franken-gramps tomorrow, but I don’t know if it has enough space on its harddrive for WOW. It was my previous machine, but WOWs size grew since than.

So if any of you are up to this, please give your oldtimers a shot, because I might fail. And share your experiences.

It would be really interesting if the current game would be able to run on some older machines with older stuff but not on our current better ones.

Stay strong :wink:

(Edit: Sorry guys, I couldn’t even upgrade WoW on the old tinman, not enough space :frowning: )