''Item cannot be modified''

Bought a PvP neck for my alt, bought 3 settings and 3 gems to upgrade it like i did on my main… but the problem is now i can’t?

What’s going on?

1 Like

I’m having the same problem and I’ve submitted a ticket

I’m having the same problem and I’ve submitted a ticket. Gm answered and could not help with it sadly

Same here, wrote a ticket ingame and it was marked as “answered” but in reality it was just a automated reply that referred me to the forums and wowhead.

Same issue with catalyst, pvp piece that you convert into tier becomes non-upgradable. Can we fix this? I have bunch of alts waiting for it.

Same. bump

There is a HUGE amount of bugs around the pvp items from this week. Blizzard seem to just be ignoring this even though it is completely game breaking for people who got their necks weeks before to be able to have the 3 sockets giving them more stats than others in a pvp enviroment.

This should have been a top priority to fix and the fact it’s been completely ignored with not even a blue post to explain what is going on is completely unacceptable.

The idea a GM can’t help in this situation is also stupid and not true, the least they could do is give you a refund on your conquest points and mail you a blue honor neck or let you item restore your previous blue honor neck. Easy fix to the problem but they can’t be bothered.

1 Like

HOW IS THIS STILL NOT FIXED? im getting really frustrated having to deal with so much buggs its starting the get laughable

Still absolutely nothing in the hotfixes for 3rd Feb. This is utterly pathetic.

Meanwhile, devs are busy fixing nonsense like this “Rare Vintage Arcwine now correctly consumes upon use.”

Sort it out.

A fix that should cover most of this issue recently went live. Relogging will be needed for those who were online while said fix was deployed so the game client can pick it up - afterwards, it should be possible to upgrade and socket most of these neckpieces. There are some very specific outliers to this that we’re still working on fixing, so please hang tight if things still aren’t quite where they should be for you - they will be soon.

Thank you for the response with some clarity on the situation.

Can see there has been some sort of fix as my ring from this weeks Great Vualt is now upgradeable. Personally my neck is still bugged so hopefully the extra fix comes in soon, hope everyone else is now able to socket their necks.

As a bit of feedback if you happen to read this, this expo has been excellent, a return to the old ways of WoW almost. It’s just a shame their is such a lack of a customer service department and I appreciate the people in the department are working hard but it is really letting the side down.


im still having this issue, but thanks for the update

Good to hear it’s being worked on but mine is still greyed out

Gladiator’s Pendant still not fixed.

When is this fix coming because seems like majority of people still can’t socket their necks?

Still not fixed :clown_face:

just here because i still cant upgrade my neck.

did anyone try to destroy the item and restore it through the item restoration service?

On the “Trending Articles” under Customer Support ingame the topic is listed and it says the following:

Our developers have fixed an issue that was causing problems. Please try again.

The current number of sockets on a neck item must to be taken into consideration before using a Tiered Medallion Setting. For example, a lower quality Tiered Medallion Setting cannot be used to add a third socket.

well, i just opened a ticket

Wouldn’t bother, had mine answered and they said they can’t do anything until they figure out how to fix the bug, took them 5 days for that response as well.

So the neck socketing seems to be fixed tomorrow on reset, however… the gladiators pendant is not among the listed items???

1 Like

Is this in any patch notes anywhere offical yet?