Low texture resolutions - pixelation - Not Fixed!

After the recent 9.0.5 patch, I experience problems with extreme degrees of pixelation on several textures. Expecially stuff like spells look like they are straight out of minecraft.

None of my settings have been changed, and I have ensured that they are all the same values as before the patch. Any help you can provide with this (I know I am not the only one seeing this)

2 Likes

Check if your graphic card has a new driver. Check on manufacture site, not in windows update.
I used to have that problem on my old card, but usualy it got solved by a driver update.
Hope you figure it out. :slight_smile:

I already did that :wink:

the problem remained after that as well.

heres the right link

Does not work. I think there may have been a general graphics problem for many users, as I notice that the pixellation issues are especiually apparant in raids or areas where many people or mobs are together. I have never seen pixellation like it before.

If you lower your graphics settings on the preset slider, then put them back, it temporarily fixes the issue, however the issue comes back when you relog or zone in anywhere.

That doesnt work either, my game still looks like minecraft no matter what I do. I have never had this problem before, so my guess is that blizz must have done something with graphics in this patch as well.

Setting Anti-Aliasing to MSAA 2x fixed it for me (for now, still waiting for an explanation why this is happening), but seems like it doesn’t help everyone.

Yeah it doesnt work for me :slight_smile:

It really annoys me, cause the game looks so weird that I dont want to play it atm. I’ll just wait untill blizzard fixes this, or someone finds a permanent solution.

Too bad :\

I was also terribly annoyed and disturbed, looking at this pixelated environment. This was kinda unexpected, I hope to hear something from technical support soon.

1 Like

Yeah me too

I have the same issue.

Same pixel stuff the above worked for me too.

It seems to be the world texures rather than the ones effected by texure filtering. (in oribos it effects the walls and pillars but not the flags)

Disable target fps under advanced settings and the pixelation will be gone.

2 Likes

There was a small update once I logged in today, so I decided to set my setting back to normal. Seems like everything is fine now, no pixelated environment so far.

I have the same problem, even after todays patch. Setting the graphics to low and then high again doesn’t help -_-

Disable target fps under advanced settings and the pixelation will be gone.

This worked, thanks Kiyuki

I just disabled the target fps and also put MSAA 2x. Now is way better! Thanks

1 Like

Those workarounds didn’t work for me !

Did you disable “target fps”?

I have the same problem. Neither of the above workarounds work.

However, I have found “Particle Density” turned to off fixes it. However, I should be running on ultra so not really acceptable…

1 Like