M1 Mac BattleNet and Agent Broken - Stopping WoW installation

For those following along here, there’s also a thread on Reddit where people are getting mixed results: https://www.reddit.com/r/macgaming/comments/14d0plr/anyone_know_whats_going_on_here/

1 Like

Same issue here

Never had issues with m1 macbook pro but trying to install wow yesterday started 10 background agent tasks and caused the machine to lag heavily

i tried to install on it a external ssd drive, not sure if that has any influence?

1 Like

I had exactly same problem with external SSD. What helped me was

  1. Deleting the agent folder before installing retail.

  2. Install to internal storage first, and later move the files to external SSD manually.

Another day, same issue, wasted money…

3 Likes

And still 1 bluepost on the forum is all we got… If there were no forum topics, Blizz even wouldn’t have replied or posted anything… Seems like they just don’t care, that’s pathetic. And we pay for THIS

1 Like

And not only the money got wasted, also weekends time that I wanted to spend playing the game, ruined

1 Like

Same issue here. Tried everything, and still no solution. Hoping this gets fixed soon. Lost the time I had set aside for the game, but hopeful about next week I guess :confused:

Deafening silence from Blizzard…

2 Likes

After completely un-installing Battle.net and all related files, i’ve tried re-installing Battle.net and World of Warcraft retail, which failed the first time, after deleting the ‘Agent’ folder completely, then re-starting Battle.net and trying to download it seemed to work for me. I had to have a lot of patience before it worked (it wasn’t instant).
Hopefully this works for others as well, either way Blizzard should fix this issue ASAP because it’s a weird work-around, which should not be the case for a game with paid subscription, it’s not a cheap game either, so they should get their things right.

1 Like

Hey, could you link the bluepost, please? I’m throwing in the towel tonight, trying to get things to work. My poor macbook is boiling hot from all the cpu usage of this bug.

Here is the only bluepost

P.S. Blizz have deleted one of my replies… This is PATHETIC.

BLIZZARD:
Fix the problem that restricts people from paying and playing the game for 10+ days – NO
Delete peoples complaints on Forum, do nothing about the problem – YES

I swear, if they don’t fix this in a few days I will abandon this ***pid company…

2 Likes

In the “World of Warcraft” root folder, check the permissions in the “Data” folders, including itself.

If there are no such folders, you need to start downloading the game through the client, and wait for the problem to reproduce. At this stage, they will be created.

My similar problem was solved when instead of “Custom” I changed the rights in absolutely all folders in this directory to “Read & Write”.

If at the time of changing the rights BattleNet was running - it will need to be restarted.

I checked the fix both when updating and when loading a new game - in both cases the method helped.

1 Like

Hi, after loads of tries, I found a solution:

  • close Battlenet
  • give full access in setting- privacy- full access disk to battlement
  • delete Agent folder
  • then open battlenet and open activity monitor
  • start to install wow
  • meanwhile in activity monitor shut down all the agent task.
    It worked for me
1 Like

Still doesn’t work, tried everything that is posted here :frowning:

1 Like

EDIT: I’ve removed my previous solution because I’ve concluded that whether it works or not seems largely a matter of luck. It appears that when the Agent.app behaves unusually or encounters an issue, there’s a slim chance that the game will be downloaded and installed without any further problems.

I happened to be lucky when I just tried it on my old 2012 iMac running Catalina (instead of my Apple Silicon MacBook). I experienced first the same issues, but later it worked, likely because the iMac’s slower speed caused the Agent.app to halt operations within the correct timeframe, resulting in a successful download and installation of the files.

So, there’s no need to meddle with folder permissions or full disk permissions. They won’t solve the issue. The key might be to terminate the Agent.app at the right moment, although I can’t specify when that would be.

>>>> THE ONLY REAL SOLUTION <<<<

The key seems to be having some pre-existing WoW game files installed. For example, if you have the WoW Classic files already located in the World of Warcraft folder within the Applications folder, Battle.net should operate without issues. The problem arises only when you try to install WoW from scratch.

If anyone needs the files, I can provide a download link from my server. It only includes WoW Classic (around 5GB). After unzipping the folder, you simply need to place it in the Applications folder, and then you should be able to install any other WoW version.

It already worked for Dmeatraw, without any issues.

You can message me on Discord at: axynokay

1 Like

Thank you for the reply, but, unfortunately, it didn’t help me to solve the problem. I also tried other suggestions from other people on Forum but ended up with the same result - failure

P.S. If you have a spare minute, please contact me in Discord - @mitra2, and probably I can share the screen for you on the call so we can look at it together

Hey, I’ll reach out to you on Discord shortly. I’ll provide a link to download the WoW Classic game files from my personal server. It appears that once some game files are in place, Battle.net will operate smoothly. The issue seems to lie primarily with downloading the game files from scratch with battle.net.

If someone also would like to have the files they can add me on discord: axynokay

2 Likes

People, a solution is here! It actually works! Girodo, a person replied here, shared a folder with already downloaded WoW Classic version of the game (up to 5Gb folder) and there what I did to make it work:

  1. Installed Battle.net
  2. I didn’t give it some permissions to Full disk access or anything, the only permission it has is App Management by Agent (by default after an installation of Battle.nett app)
  3. Closed Battle.net app
  4. Put the folder with WoW Classic into my Applications folder on MacBook
  5. Opened Battle.net app
  6. Went to WoW Classic tab and located the game folder manually

And after doing so my Retail version started to update and it went through initialization and started to download the game! I suppose, if it doesn’t start to update/download by itself, try to click the Install button manually and it should work

I’ve discovered now which files are really needed for Battle.net to function properly. In the Application folder > World of Warcraft > Data > indices, there are thousands of files (450MB) that are unreadable for me, but are essential for Battle.net to work and, for example, install WoW Classic.

It appears that once the game files are in place, Battle.net operates smoothly. The issue seems to lie primarily with downloading the game files from scratch.

So, I’ve made these necessary files available for download (450MB)
Please contact me on discord (axynokay), I can’t share links here.

After downloading, carry out the following steps:

  1. Close Battle.net.

  2. Open the Activity Monitor (Application folder > Utilities) and end all Agent.app processes.

  3. Alternatively: Restart your Mac.

  4. Go to the Application folder and delete the “World of Warcraft” folder (if it exists).

  5. Unzip the downloaded “World of Warcraft.zip” file and place it in the Application folder.

  6. Launch Battle.net, go to WoW Classic (not WOTLK) and click on “Locate the game”

  7. Select the new “World of Warcraft” folder.

  8. Install additional WoW versions if needed.

If someone needs help, contact me on Discord: axynokay

2 Likes

hi i have reached out on discord it said to add you as a friend i sent a request. i dont know what else to do this has been driving me mad.