[Main Thread] Audio Dialog stops working as if it's been turned off - April 2023

A few minutes after logging into the game, the dialog audio stops working. Clicking in NPCs, voices in cinematics, voice lines in the open world or even in instances become silent, as if I turned their volume down to zero.

What I tried to fix the issue:

  • Resetting the sound settings when this happens with the command /run Sound_GameSystem_RestartSoundSystem();
  • Toggling audio settings.
  • Change output devices.
  • Toggling dialog audio.
  • Run the Scan/Repair.

What does work:

  • Complete game restart.

I can’t reproduce this on demand, but it happens every time after 10/30 minutes - I just can’t find what triggers it.

1 Like

Having the exact same issue, cant seem to replicate. But it keeps happening.

I also have the same problem.

I have the exact same issue but only on my druid. On other characters it works fine , and I think it’s server side related , because I tried fixing it ( used like 2 hrs to try everything disabling addons/deleting WTF folder, in the end i commited to fresh install wow with no addons ) . The strange thing is I cant understand how only 1 char is bugged and rest works fine

Same, it only happens on my druid. However it seems to be only happening in dungeons now. Specifically in M+ only.

Just found this on the US forums as well:
No npc dialogue - Support / Technical Support - World of Warcraft Forums (blizzard.com)
Specifically “Dialogue” Audio disabling on it’s own - Support / Bug Report - World of Warcraft Forums (blizzard.com)
Thundering Affix Sounds Not Working - Support / Bug Report - World of Warcraft Forums (blizzard.com)
No npc dialogue - Support / Technical Support - World of Warcraft Forums (blizzard.com)

Entering a dungeon seems to break this as well. I did it a couple times, every single time, the dialogues stopped working.

Restarting the game fixes it every time.

Taken from the US forums.

So for anyone having issues with either:

  • Dialogue turning off randomly.
  • Certain options/cvars not saving.
  • Ambience Volume defaulting to 0.60 or anything else.

You can temporarily fix this by commenting out 2 lines in LibOpenRaid.lua found in: World of Warcraft_retail_\Interface\AddOns\Details\Libs\LibOpenRaid

As described here: https://github.com/Tercioo/Details-Damage-Meter/issues/479#issuecomment-1482393401

Until Blizzrd comes with a fix, or when addon developers find a work around.

1 Like

This is extremely useful info, thanks!

You can use this addon on Retail to workaround the Details CVar overrun bug. Blizzard will need to fix their code to guard against this behaviour too.

There may be a delay before it’s available. Curse approvals are slow.

Addon also available here.


It doesn’t seem to be only related to the libs used in details anymore. Addons that interfere with the “TalkingHeadFrame” are also causing this now.

Which you can read about here on the US forums: TalkingHeadFrame:CloseImmediately() Breaking NPC Dialog - Guides / UI and Macro - World of Warcraft Forums (blizzard.com).

However, more and more people with no addons at all are also reporting this now. Most specificaly in dungeons such as Halls of Valor and Court of Stars.

Also found this on the US forums while digging a little further: [BUG] Addons able to break game settings when using C_CVar.RegisterCVar API - Support / Bug Report - World of Warcraft Forums (blizzard.com).

Yeah, there’s probably two issues at play. I’ve noticed the audio cutout bug just by doing Forbidden Reach quests.

Details is triggering the CVar length overflow bug though, which causes settings to get corrupted.

Funny thing is, even though i had those 2 cvars commented out. Everything still broke last night in Court of Stars, while i have no addons interfering with the TalkingHeadFrame. Also monitored the config.wtf at that time and nothing was re/overwritten…

It is also posted on CVars with large values clobber others when written to disk · Issue #410 · Stanzilla/WoWUIBugs · GitHub so hopefully Blizzard will pick this up fast.

Of my installed addons only Details is using C_CVar.RegisterCVar. Search all lua files in your addon folder for ‘C_CVar.RegisterCVar’ and see what comes up.

Notepad++ is quick for doing this. A pretty big bungle from Blizz though, yeah.

And no1 answered from Blizzard about this problem…Idk why…

1 Like

I have this issue as well. quite annoying.

The issue is caused by World quest tracker addon. Disable supress talking heads in options menu. Fixed it for me. Hope this helps :slight_smile:

It’s caused by any addon that auto closes talking head frames. It’s a bug in Blizzard’s code.

This is happening to me and 2 of my friends also, With no addons and with addons it’s the same problem. No dialogue sound.
Please at least respond that you are looking into it blizz.

1 Like