Micro stuttering since 10.2

Since the new update today I have micro stuttering every 2-3 seconds. No matter what instanced content, city, etc. Even on two different PCs.

My specs. PC1:
i9 13900k
RTX4080
64 GB Ram
Win 10

PC2:
R7 3700X
GTX 1070
16 GB Ram
Win 10

2 Likes

Does it stutter even when no players are around or just when people are flying and mounting up?
Did you update all addons for the new patch?

I even did a fresh install without addons. And I still have the micro stuttering everywhere. No matter if in Valdrakken, flying around or if I’m doing old instanced content alone.

Now you know how some of us have had it ever since Df pre-patch, it sucks.

1 Like

I have had the same problems, tried no addons, tried tinkering with settings. it doesnt say my fps is getting lower but i swear it looks like it is

3 Likes

Had? Could you fix the problem?

i did some stuff but it feels like im still lagging and i hope its not placebo lol

1 Like

Haha. I hope they will fix it soon!

1 Like

Yep i noticed it today too i have an rtx 3090ti r7 5800x3d 32gb ram and on ssd, getting way above 200 fps in some areas but the game feels stuttery and not smooth.

i unsubbed because of that and now its returned xD i guess staying unsubbed untill this company actually have good devs is the right answer.

Still micro stuttering. I hope they will fix it soon.

1 Like

Do you have gsync?
If so enable vsync in the nv control panel, limit your fps 3-4 below your displays refreshrate or simply turn on Reflex ingame (should limit your fps automatically below max refresh).
Switch to DX12.
This makes the game smooth for me except for the engine stutters.

So guys I fixed this issue for myself by doing the following: use these 2 commands
/console cvar_reset
/console cvar_default
Then make sure afterwards you have anti-aliasing disabled and use direct11 legacy. I have no more stutters!

DX11 is so bad, especially if you play videos on a 2nd monitor (they WILL stutter), and overall worse performance. As for the stuttering it’s about the same across all the APIs. This also happens on literally new PCs, fresh Windows, drivers, default cVars etc.

It might be the anti-aliasing then, because that completely took away my stuttering

Welcome to PC gaming in the year 2007 :slight_smile:

For me it is reversed, if i use DX11 and play a video on my 2nd display, the game stutters even if the FPS are 140+.
In my case this is a known problem if you have 2 or more displays but with different refreshrates.
My main LG is 144hz gsync and my 2nd is for production but only 60Hz.
So i just bought a 2nd LG (144Hz) on sale for 200€ which should fix that problem.
I will report back :slight_smile:

Which AA method?
Have you tried FXAA, CMAA and Multisample?
Also make sure your renderscale is at 100% as it is bugged right now and causes FPS issues!

I cap my main monitor at 120 hz and my 2nd one is just a simple 60 hz monitor. I don’t have video stutters in DX12 or Vulkan games.

The problem is only in DX11.
Just installed the 2nd LG Display with 144Hz and tested it in DX11 and no stutters anymore :slight_smile:

I still have this issues… with DX12.

after some testing i found a possible fix for the stutters on fixed framerate,use the in game frame limiter to the same refresh rate of your monitor makes the game smooth again,using vsync alone will have stutters,but using the game frame limiter makes it like it used to be,fixed framerate and frametime,and no stutters,test it and tell me how it goes.

ofc ,for dx12,because 11 works normal.