Shadowlands flickering badly after update to Nvidia 460.89

Thank you, your solution worked flawlessly. Do you know who originally came up with it? You should forward this to the people @ nVidia :slight_smile:

I was fine for the last few days but as soon as I load the game now it is flickering like a strobe light.

I have same as you RTX 2070 and v461.09.

Rolling back to v460.89 worked to resolve the issue

Its not that fully just tested still flickers on my 3080

It’s from a user on Guru3d. Nvidia is aware.

Still flickering on 3070 and 1060S (2 different pcs). Disabling Anti Aliasing helps. As soon as I use FXAA or MSAA the flickering begins. RT on/off doesnt matter, its just with AA. Nvidia driver 461.09

FYI going into System and Advanced and changing Graphics card from Auto Detect to my card fixed the flickering

3 Likes

I have found a fix for my flickering textures. Ive had very terrible perma flickering in outdoor venthyr areas especially on buildings, streets and trees. Even inside the the Venthyr dungeon.

I found out that my Firefox Internet Browser was running all the time in the background and the active window was a twitch stream or twitch in general.

So i closed FIrefox and opened the twich desktop app and since then ive had not a single issue.

I didnt try to re-enable the problem because im happy that its gone, but yeah that fixed it for me entirely. Hope nvidia gets their $§U% together x)

edit: I also run the latest nvidia driver right now.

And btw: Could someone with an US account plz post my meassage in their general thread there?

its this one. If it helps at least one person its worth it :slight_smile:

1 Like

I posted the fix a few posts above yours. It’s not magic.

Hi all,

So here is what i found fixed it for me.

Go to SYSTEM<Advanced<Graphics Card, make sure your card is selected here and not some onboard card or Autodetect, Manually set your card here.

Once i made this change boom fixed, hope it helps others

Peace

1 Like

I have it too. But I set wow to use Dx11 and it appears to be resolved =)

Wierdly I’m on 457.51 I sometimes notice small fast flickering faded black squares on the map (whole shadowlands map) in oribos.

https://www.youtube.com/watch?v=S-KVPmn1pnk&feature=youtu.be video of the issue.Wierdly the map UI starts to flicker before it happens on the map.

They pop up randomly on the shadowlands map only while I’m on oribos. (sometimes even outside of oribos)

I managed to cause the issue by having the shadowlands map open while using the teleporter to go to the 2nd floor in oribos.

yup still the same problem with textures flickering with the newest 461.72v February 25, 2021 drivers. Last working are 457.51v from December 2, 2020. Almost 3 months and they still haven’t fixed them :o

You are the man!!! This works!

461.92 still not fixed - 2080 rtx ti

I fixed the issue by setting MSAA to “none” - I have the second latest nVidia driver. :skull:

Dear people from Blizzard - 3 months is really enough for this bug. Its really, really bad. Either change something on your side or make more pressure on nvidias side. They are your partner and should not leave you hanging like this.

3 Likes

This post helped me out:

Setting ID_0x006d6197 to 0xa2b53761 solves the issue. As the post states it “disables a DX12 optimization in the driver”.

1 Like

It’s definitely Nvidia’s side. They have a whole load of bugs they’ve been desperately trying to fix since their newer fancy vid cards have come out.

I saw someone suggest this in the US Main Thread on this issue:

Enter the game, open System (settings), open Advanced, click Graphics Card, then enter the option that is precisely your graphics card, instead of “Auto Detect”.

For me this fixed the flickering issue and I haven’t seen any flickering since.
Edit: It seems this has already been mentioned 22 days ago here. I will still leave the message in case anyone finds it useful.

This is a temporary solution, but the issue comes back when you change zone or exit/re-enter the game again.
This is super bad for eyes, and the issue is ongoing for quite some time now. Do we have any information as to what’s being done about it?
It’s being addressed on NVidia forums, but driver after driver update we’re not getting a fix for this still.

4 Likes