Shadowlands flickering badly after update to Nvidia 460.89

As title says. WoW flicker realy badly again after update to 460.89. The only solution is to roll back to 457.51 becouse 460.79 also makes game flicker.

23 Likes

Same issue here, enabling rtx shadows improves it but only slightly, rolled back to 457.51 which resolved it, running on a 3070.
Theres a similar thread on US forums regarding 460.79 having the same issue so deffo a problem with the recent Nvidia drivers.

3 Likes

I’m having the same issue, also after the most recent nvidia update. If you don’t mind, could you please tell me how i roll back to a previous version?

1 Like

Me too. Some players says that after putting waters graphics to low, this flickering is gone, but I need to try this out tomorrow.

same here … but only in dungeon Theater of pain same platform first and last boss … flor missing

Try disabling DX 12 if you have it enabled, that worked for me :slight_smile:

14 Likes

We have seen this problem before. The easiest here-and-now solution is to change the version of DirectX that WoW is using to 11 (down from 12). It’s done by pressing ESC --> System --> Advanced —> Graphics API. Further down the road a patch from either Nvidia or Blizzard will fix the problem permanently.

16 Likes

I’m running in DX12 with the Cyberpunk drivers on a 2070S, Windows 10 (ver 2004) and no problems whatsoever.

Same problem after updating to the latest nvidia drivers

1 Like

Have the same problem. Already installed the update 457.51. Still have flickering at Spires of Ascension at the platform of the last boss.

1 Like

i’ve had the same issues, was driving me insane, really wished i’d looked here earlier. I’d disabled all addons, put graphics to min but nothing made any difference. My fps was all over the place , bouncing from ~45 down to 5.
So following the advice I’ve done a clean reinstall of 457.51 .
So far, its running smooth again. I can go near a city again without ridiculous fps stuttering

1 Like

Had the same issue with driver 460.89. The issue seems to disappear toggling off ‘vertical sync’. Been playing without any flickering for the last 30 minutes.

2 Likes

Same issue here after updating to 460.97 from 456.71.

1 Like

Same issue here. Playing on a AMD5600x with RTX3070.
GeForce Drivers: 460.89.

1 Like

Here the same situation, flickering that seems to get better when deactivate anti-aliasing and impossible to play when activate the best anti-aliasing.

Intel® Core™ i7-7820X CPU @ 3.60GHz 3.60 GHz
32.0 GB (31.7 GB usable)
EVGA RTX 2080
GeForce Drivers: 460.89
Windows 10 Home (totally upgraded)

1 Like

Got same problem with 460.89 and 460.79 on both version i got strange flick and looks like i don’t see all spells on ground ppl report i stay in something but on screen i got nothing.
Windows 10 prof. with full updates and I use ultra settings.

1 Like

Hi there,

Thanks for the reports!

Indeed we’re aware of this issue happening on several different 460.xx driver versions.

For more info and currently known workarounds, check out the thread here:

3 Likes

Like Lai say download and install 457.51 i just tested and working good.

Best regards!

1 Like

RTX 2070 confirm. After updating the drivers (now v461.09), some of the textures flicker.

Here’s a temporary fix if you want to be on the latest drivers.
Download Nvidiainspector and import this profile:
https://cdn.discordapp.com/attachments/247515315825672203/797266981631950884/World_Of_Warcraft_-_Retail.nip

It’s the same profile that is in the 457 drivers but for some reason Nvidia removed it in the 460’s.

3 Likes