(Solved) Please help, I abandoned the Human heritage armor quest and I can't find

The solution that worked for me is that I purchased the tabard, wore it, went to Valdrakken, and came back to stormwind, and the quest appeared and the NPC Angent Render also appeared near the Stormwind embassy. TY all for help.

If you meant the Core Human heritage armor:

Yes I know, but I can’t find it, the NPC is not there.

Try relogging or using /reload when near the approximate location and turning on “trivial quests”.

Didn’t help either. I also search for that NPC with a slash target macro, he is just not there.

Edit: See Shilmael’s post below.

Hello Zampatext,

In this case you should be able to pick up the quest again from Agent Render, this NPC is located near the Stormwind Embassy next to a tree.


He is not there either. And the wowhead page shows no quest too.

Do you have another Human level 50 or above?

Yeah but no reputation with stormwind.

What about the lions pride inn or morgan’s vigil in burning stepps? Raven hill or Moonbrook? Northshire?

How far EXACTLY where you along the questline?

I just finished it on a level 52, that hit 54 doing this quest. Took me 35 minutes or so and was really easy.

It was on this Dottie

1 Like