Stuck in "logging in to game server"

So I connect, retrieve realm list, then I get stuck on “logging in to game server” for awhile before getting “You have been disconnected (WOW51900102)”

This is on classic btw.


Getting the same error, sometimes error 51900319 too which is a generic disconnect error. I am on retail.


im having the same exact issue on BfA

Same issue here.

Same on retail, started happening like 5 minutes ago

1 Like

Yep same here…

I was afraid it was a -me- problem.

I’ve been trying to log in BfA and I’m having the same issue.
Then I tried Classic and also same :confused:


Same issue here :confused:

just had this happen as well

same here, was thinking it’s only be happy it aint

1 Like

Same here, game was fine 30 mins ago, but now can’t log into realms at all

This is on retail, haven’t tried Classic yet but it seems thats down too, must be a EU server issue b’cos US is OK

1 Like

Same. Both Classic and Retail.

I have the same issue, cannot login, getting the same error as original poster.

Same here - got stuck on an island expidition (DC I thought) restarted and get same error. 5 mins ago

Same. Same. Classic + Retail.

Would be cool if the game would work without this BS on a weekly basis.

1 Like

Echoing others with this issue. Both classic and retail.

Same here on classic.

Tried logging in to retail after getting WOW51900102 error on classic. Same result.
Edit: Worked fine when I logged in 1 hour ago.

Same error here