Trading Post – All Item Purchases Are Temporarily Non-Refundable

Due to some issues that are affecting the refund process, the ability to refund any items purchased from the Trading Post has temporarily been disabled. The Customer Support Team will not be able to assist with refunds while these issues are active.

Updates will be posted once this situation is resolved and we expect all applicable Trading Post item purchases to be refundable at that time, including items purchased during the nonrefundable period.

Thank you for your patience.


Thank you for the communication.

Omg whaaat!!! I made a huge mistake to just test and thought I can refund it c’mon :sob::sob::sob: Does the Refund timer stay frozen, if I just don’t log in?

what about the fact the trader is not working at all, lost 900 coins due to not getting the item.


Lost 750 with the same issue.
Tried to buy the Fury of the Firelord, it sat and thought for a bit, spat me an error, took my tender and gave me nothing.
Won’t let me buy anything else now, which is better than stealing limited currency I suppose


Can Blizzard confirm when The Trading Post will be ready for use?

next time i wont complain about extended maintenance just make it all work

1 Like

Thats okay, I wasn’t planning on buying any of them anyway. They’re pretty boring tbh.


What? It’s the coolest void theme staff in the game, and the coolest warrior weapons with one of the coolest pets -.- The Mount is also really awesome… Best thing is, that we just get it for our sub :smile:

Thanks for the communication, but I (and several others I spoke to) are unable to loot the chest with trader’s tender, it sparkles and is clickable, but when you click it all that happen is the opening animation of the chest and no loot window appears and no tenders are added to you. And when you check the shop it says you have 0 tender but you have unclaimed tender in the chest.

So yeah, can’t do anything at the moment, tried relogging, disabling addons, trying it on another character etc. Nothing works.

1 Like

A Purple version of a WOD staff that I have pretty much every recolour of, and a Weapon for a Class I don’t even play?

The Celestial Mount, an old shop mount that I pre-emptively bought in the Xmas sale using WoW Gold with the intention of saving Tendies for something in the future.

I was looking forward to the Pirate Outfit, but in all honesty, I’ll just stick with the Transmog I’ve collected in game.

Kill 40 Dungeon Bosses.
Kill 30 Raid Bosses
Do 15 Pet Battles.
Complete 15 M+ Dungeons.

Need I go on?

I also made the mistake and bought the one handed mace… I have opened a ticket but never…

So why are you here? If you don’t want to use it then please stop cluttering a thread about real issues.

I don’t care about the refunding, but what about those of us that finished the 1000 coins and should get mount? The chest only contained 300 coins, no mount in bags, no mount in mailbox and no mount in collection.


I’m giving Feedback in a suitable place, i.e. a Blue Post topic about the Trading Post.

It’s better than starting a new Thread about it. There are too many moan threads on this forum already, so I didn’t see the need to make a new one.

1 Like

Oh my god, we have to play the game to get something! The horror!

1 Like

I was pointing out to the person I was responding to that it wasn’t just something we go with our sub.

It was something we had to work for in the game.

I bought 750 coins of Fury of The Firelord but I got an error with blizzard servers and I never received my item. My 750 coins are gone and I didn’t receive anything…

1 Like

I’ve completed enough tasks to get 1000 Trader’s Tender, but when opening the chest I’ve only received 400… how to get the other 600? (total 1900 at the moment, not sure if thats expected?)

Edit: I misunderstood, 1000 points in the Journal does not equal 1000 tender. You receive 100 tender at 200,400,600 and 800 points so working as intended.

1 Like

got the exact same issue. hopefully theyll at least refund the currency or something