Trading Post Issue and Fix Underway

It does suck. Hopefully everyone will be caught up after the reset.

It finally gave me the mount but the 0/1000 progress bar visual bug is still up and it doesn’t show the amount of currency I have when I switch to any of my alts. The vendor screen is also affected by this visual bug and it’s very annoying.

When fix?..

I didn’t get the mount either in any way suggested by the helpful posts about it or alternative methods. I hope this is given priority in the next patch. I love the design of the mount and would be really frustrated if I didn’t get it.

i just completed my task for the mount and yet again it feels like they don’t try to fix the problem

1 Like

Add my name to the list, I didn’t get the mount, i can’t click the chest.
Sometimes in the log it says i’ve claimed the reward for this month, other times my progress has reset back to zero, but show that i’ve completed activities in the list below.
Please give the dev team more time to test before releasing content, I think some people were able to buy and sell back all the items, but still keep the transmogs the day it was released, it just feels rushed out.

I’m having the same problem, I hope it gets better, I finished the contract, but nothing came.

Mine caught up today and maxed the bar, chest gave me 300 coin and the mount has not appeared in collection, the mail or my bags :pinched_fingers: took 3 attempts to fill the bar with resets

I wonder how much longer we have to wait for the bug to be fixed… frustrating… :frowning:

Same bugs here, can’t open it. with or without addons, after a UI reset. nothing is working.

No mount here either.

WTF, i logged out and now my whole progress bar has been reset?

A very observant person on the US forums asked why something that isn’t working is being advertised on the bnet launcher. I have added game time to my account earlier today and the entire feature is inaccessible saying how it requires active game time.

Should I add two more months in good faith, maybe it starts working then?

Same issue here as well. Opened the chest and got only the coins or whatever they are, but not the mount

No, I would say just wait and see. They still have a few weeks to fix this till next month. You have active game time now so it shouldn’t be an issue.

Same here. No mount.

Just got the missing mount. Seems to be fixed.

1 Like

No such luck here. Still no tender at all, nor mount from the full bar. Hoping they fix it in weekly maintenance!

I logged in this morning and was still unable to collect my mount or tender, tried several times throughout the day on my main. But then I relogged around to some of my alts and eventually one of them was able to open the Collector’s Chest. Got my 2000 tender and the mount at last.

1 Like

Got my mount and tender, however I have no Progress for the year long Trading Post Achievement for the Warden Transmog. Hope this get’s fixed.