Trading post stole coins

Used the trader to buy the “Fury of the Firelord” 1h Mace which took the 750 coins but never gave me the time but removed the coins from my account.


Exactly the SAME thing happened to me. Now no tmog and points are GONE! And quest completion gives me 0 points tho it says 500. Like???

1 Like

Same issue. Tried to buy the Rosy Corsage, twice it didn’t do anything, third time it took my tenders and still didn’t give me the mog.

1 Like

Same with my wife. Personally i finished some parts for coins and didn’t recieve any. Trading Post is a complete bug infested fiesta.

Same issue here, bought ‘Fury of the firelord’ without problems, then bought the ‘Shattered voidspire’ but that didn’t register and only took my coins -_-

Same. Got the Swashbuckler, had endless errors. Post took 650 coins and didn’t give me my mog.

Hey all,

Our developers are aware of several issues with the Trading Post, and it is unfortunately being disabled for the time being. The information that we have so far isn’t much I’m afraid, but we’ll try to keep you posted on what’s happening. :pray:


I just filled up the bar to 100% on Trading Post and I didn’t get my tiger mount “Ash’adar, Harbinger of Dawn”. I only got 200 tenders after opening up the chest and that’s it. Is anyone else having this issue or am I missing something?


Same for me. I’ve made a Ticket ingame aswell.

1 Like

Good day,

Neither finishing the intro quest for trading post nor opening the cache gave me any tokens. The quest is now completed, but I am sitting at zero tokens.

The cache keeps glowing and for a second I can target it with a golden cogwheel, but nothing happens.

A bit dissappointed, hopefully this is fixed.

Same for me. I have only 500 (from the achievement I think) but I’ve done the quest and opened the chest, and should even have 100 more for doing optional storyline in the Waking Shores.

I opened a ticket but I’m really hoping a blanket fix will be implemented because I’m not optimistic about ticket response time.

when i opened the chest after getting 1k i got 800 coins but no mount, now it says youve collected all the rewards for this month.

same here and its not listed as an existing mount in the mount journal, i have seen some people using it so something is wrong here. So we have some people that have currency stolen from them and some people are not getting the mount after reaching max

Same here, says I have 1600 uncollected tender in the Collector’s Cache and I can right click to open it. It does the opening animation but I don’t get any currency.

I can update that I got the ones from the chest now. The quest seems to be still bugged though.

I got the currency once i clicked the cache first, then i completed the quest, but got no reward. I also completed a few activities from the log and i still can’t claim the currency nor does it say anywhere that i have unclaimed currency.

Same for me. I’ve tried with several characters but still I don’t get any currency. Any news?

Yeah still unable to open the chest, tried on a few alts as well.

1 Like

Same for me, managed to get the first 1000, but not any more

Did the whole bar, got some tenders when i opened the cache but no mount. Is this gonna be addressed as well ?