Trading post stole coins

First bought that Transmoggset, payed the coins but didn’t get the set. Coins are gone.
Dis some things to earn more coins, some of them are finished but i didn’t got the coins.

1 Like

Same, same. It took coins but I never got the mog.

I successfully bought the Celestial Steed this morning, it was in my collection and I used it a bit.
Logged in now and found it gone from my mounts, along with all progress I had on the Traveler’s Log. I have no idea how many Tenders I have at this point.

that’s exactly what happened to me

update: now my currency is gone from my account and the progress gone from the log :rofl:

edit 2: i guess it’s because they locked the event for now. the npcs say they lost the key, but the currency is locked safe in the chest, i’m in tears :rofl:

Some of my progress has been reverted as well. I was at 100% complete and now I am at 800/1000…

Edit: my “complete 30 quests” was complete and now it’s not… :frowning:

My progress towards my travel points has been wiped too, was almost finished and now it’s practically empty. Did the world boss, crafting orders, rep, quests and was working on another and now it’s all gone.

1 Like

Same, all wiped clean… I wanna scream XD

While the Trading Post progress bar has been wiped for me the tasks are still showing a completed to hopefully it’s not completely lost.

Hey all,

An update from our developers has been posted here:

1 Like

Hi so the fix has happened and you reopened the trading post however my coins are still missing and I dont have the item “fury of the firelord” mace that I used them on still?

had 800/1000 and had to redo one of the tasks. After that"lootet" 400 coins from the chest today and the mount for 1000/1000. But… I still have only 350 coins, no mount, no transmogg… so where are all my coins gone??

I have no points. was given not points and cannot loot the chest. Only getting this message:

Is a fix in the works?

So I got the flail to, never received it, “fix” didn’t change anything, still at 350 tender. Box keeps showing as giving me 500 tender but it never does and I’ve not received the flail either.

Problem with “Trading Post Enthusiast” too.
Why do players have different progress in this achievement?

There’s a sticky up at the US side for known issues, for other not mentioned issues they’re also working on it:

Just got home and tried again today, still can’t open the chest. (I’ve capped it out now as well so should have 2000?)

Currently displaying this on the vendor:

1 Like

Having the same issue after the “fix”. The trading post is definitely not fixed yet.

I am unable to loot the mount or any coins. The chest opens, but nothing happens.
Obviously I’m not able to buy anything either, because I can’t loot any traders tenders from the box.

  • Tried going to an instance
  • Tried logging out for over 30mins
  • Tried logging another character
  • Tried disabling all addons
  • Tried restarting bNet

Nothing works.

1 Like

Unable to pick up the intro quest for 500 currency after abandoning it by mistake. Doesn’t pop up in Valdrakken, cannot be started through the adventure journal on any of the characters from both factions, not even freshly created ones.

I’ve not had this issue, I bought the Celestial Steed for 900 tenders. I received the mount even ran around on it for a bit all before Blizzard disabled the Trading Post yesterday. Logged on today and the mount is no longer in my mount journal and I haven’t been refunded the 900 tenders I paid for it!

Blizzard have had the Trading Post on live for a week now, why not in the week do an introductory quest where you gain 100 tenders and use it to buy a cosmetic hat or some random crap. I love that they are adding more evergreen stuff to the game but please for the love of Illidan: test that sh!t.

For missing purchases with Tender, the issue should be fixed shortly:

If you have new bugs to report do so through the ingame button.