Unplayable Low FPS Spikes - Maybe fixed

I usually sit around 150 fps, Since recent patch i have been unable to do any M+ or raiding at all, and reduced fps overall in world map.

As soon as i start fighting monsters in m+ i get a sudden fps drop to 0-1 frames. for about 2-3 seconds. This makes the game entirely unplayable for me.
The only thing i have changed is the recent patch 10.0.5.

My PC Specs:

Windows 10 Pro - 64 bit
Intel(R) Core™ i9-10900k CPU @3.70 GHz
32 Gb RAM
Nvidia GeForce RTX 3080 Ti

I should not be struggling with FPS issues.
Nvidia Experience suggests i run the client on ultra settings, which i have done absolutely fine for months.

Recent attempts to fix issues:

  • Use ingame commands “/console cvar_default” and “/console cvar_reset”
  • Make sure max foreground FPS is not set to 0 (its set at 200 but tried with enabled/disabled)
  • Disable anti-aliasing
  • Delete Cache folder
  • Turn off all addons
  • Update Nvidia Drivers
  • Run Windows update
  • Turn all graphics settings to low
  • Only run wow and no other software in the background
  • Fresh install of wow.

With all the above things attempted i still cannot prevent my client from having Low FPS spikes, wether in M+ or whilst fighting training dummies. I also have reduced FPS whilst in Valdrakken or other cities, normally 120fps in these areas but getting 40 fps (it was 7fps until i used “/console cvar_default” command)

Try turning off the Advance Combat Log settings.

Hope this helps :slight_smile:

I think i have found a fix - TL;DR its a bug with the clients own functionality
(tested without any addons in the install folder to ensure no addons are being loaded in the background but disabled via in game menu)

So after ready many forum posts about the same issue, i came across a CM post (which dismisses this as an addon issue but evidence suggests otherwise)

In addition to the mention of data parsing from combat logs, I also saw posts elsewhere that mentioned advanced combat logging.

So… The Fix!!!


Found by going Game Menu > Options > Netork > Advanced Combat Logging

After disabling this (RIP warrcraft logs) i dont seem to be getting this FPS spike, even when i re-install addons such as details which records combat actions i believe?

This is a wow’s own function that i have disabled which suggests it is an issue with the client recording and saving the combat logs and not an addon causing the errors.

Its also worth noting. Raider IO desktop app tries to enable advanced combat logging and will attempt to re-enable it.

remove that app and update it manually or with curseforge.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.