Wrong Hotkeys

I did this and only Ö key works. §,Ä and Å still not working.

This has done nothing for the § + ´ keys on Finnish layout

Have tried ticked and unticked with restarts

Same here, Finnish layout as well.

This is the random support answer “windows settings are the problem” and this even has been posted in 2019 alrdy and didnt help anyone…pls dont use old knwoledge and just randomly post it again as a solution when WOW and not Windows is the problem…

1 Like

This does absolutely nothing. Windows settings are not the problem, and suggesting changing them is terrible advice since it can cause problems with other software.

This is a bug in your game, a bug that would usually be noticed very early on in quality control in any present day software dev team with an international market.

plez fix a bit faster.

Also this does not even work, since you cannot bind keys/symbols that would require shift to use them… it will only bind as shift+’, for example, when trying to get the proper keybind.

This needs to be fixed asap, please. This is a pain for anyone with a different language than English, using keybinds apart from 0 to 9. Also you may want to test these kinds of things in the future before pushing a patch. A tip would be to hire some more QA-testers.

This was known and alrdy reported on the ptr but they just seem to not give a damn

3 Likes

Really? That is actually extremely embarassing.

3 Likes

I have a similar issue, Im using an English layout keyboard but since the patch the only keybind its killed for me is the # key which is a main bind for me as I use the right hand side of the keyboard. Works fine on Classic servers.

1 Like

I’m facing this issue as well and quickly realized the problem it’s isolated to World of Warcraft.
I have a qwerty keyboard running a Danish keyboard layout working perfectly everywhere BUT WoW…

I’ve checked all available relevant setting and made sure to update drivers for good measure…
My ‘½’ has turned into a backwards backslash

Same issue for me - I have a UK English keyboard and when I hit the hash key (#) for keybinds (which I use for my mount) I am now getting the apostrophe (’) key instead.

What worked for me:

  1. Set keyboard layout in windows to US (once it is added, you can quick swap with shift+alt or win+space)
  2. rebind the language specific key to the same button as it was before (game will recognize it as a different character now according to the us layout)
  3. switch back to your original keyboard layout in windows

It seems even if your keyboard is set to language specific layout, the game only recognizes the key press as it was US layout.

1 Like

This isnt really a solution.
Why hotkeys have been forced to a differnt keyboard layout is bizzare, no one should have to change windows keybinds for WoW to work with our language keybinds

1 Like

Since Shadowlands the game reloads and flips around hotkey 1 and 2 on each login. Which looks really odd in some cases if, say, you have a row where most keys are Shift-something then suddenly Mouse 4 shows on a button instead. Maybe you could have a look at that while you’re at it, let our choice for what is hotkey 1 and 2 actually stick again.

i don’t understand how this can happen. chat works so why are hotkeys using a different keybord layout source. looks like it was tested with us layout and someone fixed it with hardcoded this layout with the new mousover feature. :man_shrugging:

Because they a) don’t listen to feedback or bug reports on the Public Test Realm, b) don’t play/test their own game anymore and c) especially don’t care about the European market.

3 Likes

Same problem with a keyboard in german layout.
And I agree, it is NOT a solution to change language settings in windows when clearly the problem is wow-related.
pls fix

1 Like

+1, this is extremely annoying to the blöblöblö languages

This is not acceptable.

1 Like