You have been disconnected (WOW51900123)

Hello. I’m getting this error when attempt to log on without already being logged in to the Battle.net client. The info page for the error suggests that my input is incorrect for user/password, but they are correct. I’ve tried with a PC where I am logged in to Battle.net in the launcher and it works fine there, with the same credentials as I’m attempting to use without the Battle.net login.

I guess my problem is similar to these threads, I was unsure whether to post a “me too” in one of those or create a new thread:

See this issue: Unable to log in using .exe file - #13 by Apricot-thunderhorn

Yes, I’ve read that thread, and it is the first link in my post. It’s likely the same issue.

Same issue today. Reee.

To everybody having this issue, just disable your wow authenticator, we can turn it back on once they fix this, ive tried literally everything, network adapters, changing DNS adresses, etc etc and even using other devices for 4 hours straight and the only solution was turning off their mobile app which is disabling their own game, such miraculous coding

I’ll put this in bold letters: Please do not do this; it will severely compromise the security of your account.

A fix for logins happening outside the battle.net application is in the works and should be deployed soon ™. For the time being, logging in through the battle.net app (which, for the record, has always been the preferred method) will work for everyone affected by this.

I had this error 2 days ago, yesterday i was able to login using authenticator code, today this error appears again.

“Just comply, consumer”

No.

@Disassembler: It’s working for me tonight.