Continuous Issue of being stuck on Loading Screens

Hi guys.
Let’s get to it. Whenever I start the game, or use a portal to go somewhere, even when I enter in an instance(raid, dungeon etc.) I’m dealing with this. I get stuck at %70 of the loading screen, or at %0. And I can only deal with it by doing an alt f4 and retrying the same action. It’s been like this since 8.3, and I did all the fresh install thingies CRs usually direct us to. So I’ll need a different kind of direction to solve this. By the way my internet connection is also fine. It didn’t suddenly perform poorly with 8.3 .

Thanks in advance, have a great day. :slight_smile:

36 Likes

Hello Elandura,

Sorry to hear that you’re having issues.

Please first perform all of the the following steps:

If the issue persists please submit a ticket here:
https://eu.battle.net/support/en/help/contact/164/ticket

Including your MSINFO file as shown in this guide:

Hello, do you use HDD or SSD drive? If HDD can you post it’s model?

It’s on SSD. OCZ TL100 240 GB. It’s been good since the beginning of BfA, and I did everything that generic GM answer directed me to, since they don’t actually read anything, they still gave me the same advice. It’s been like this since 8.3, and I know I’m not the only one with the problem, I read the forums, people didn’t care to open a topic themselves but put it under some other issue’s thread.


People of Blizzard, when any customer sends you their complaint, please read it thoroughly. I specificly told you that I did all of those things. Now I’ll send my system info from the link you provided. They won’t find any problems, on my side, only then you’ll start to investigate things on your side, which is patience consuming and infuriating. But still, thank you for the answer.

5 Likes

Hey,

This might be a long stretch, but are you perhaps using a Radeon graphics card? I’ve had the exact same issue happening for a while now whenever I launch WoW. I’ve also had some other games like OW or Dota2 blackscreen my computer.

After a few days of searching for known issues, I realized, that the new AMD Radeon Software that uses a feature called “Wattman”, to regulate your gc’s power consumption and output, might accidentally overload the gc and cause it to crash or work incorrectly. So the solution was to either rollback the drivers to somewhere in November, where the Radeon Software feature was an option during install and you could skip it, or the second idea, as soon as Windows start up, go to task manager and shut down the “Radeon AMD Software Host” and “Radeon AMD Software Overlay” processes. This seems to fix the issue and I have 0 problems from there on.

NOTE: There are comments online about a similar issue with GeForce gc’s, same solution, close down the software and overlays if there are any. This does not effect the drivers!

TL;DR: If using Radeon gc, use task manager to close “Radeon AMD Software Host and Overlay” processes.

Hope this helps! :slight_smile:

The thing is, this is a computer that ran WoW stable since the beginning of BfA. There were problems, but all of them ended up being on Blizzard’s side.
I always updated my windows installation, sometimes did fresh installs, my drivers are always up-to-date. But to soothe your curiosity, I have an Asus GT 1030, 8 gigs of RAM, i5 4590 processor.

I too have this exact same issue. It either doesnt move at all(stuck at 0%) or it moves to around 70% and stops there. Only thing i can do is Alt-F4.

I have this exact same problem that started today.
I was leveling an alt, ran a few dungeons, no problem, then i got into Halls of Lightning or Halls of Stone, not sure which, the loading screen froze at 0%, alt+F4, i probably got kicked because when i logged back in i was in OG again, queued again, got the same dungeon, it got stuck again, alt+f4 again, i was back in OG but still in the group, so teleported into the dungeon, now the loading went to 100% then i got logged out with the message “a character with that name already exists”, restarted the game, same message, logged onto another character then back to this one, same message several times.
After about 10-15 minutes i tried again and i ended up where my HS takes me not where i entered the instance.

2 Likes

I have this problem a lot the last few days, and two of my friends also gets stuck on the loading screen a lot.
Seems more like a problem from server side than addons, even if my friend logged into another character his “stuck online character” in a loading screen, was still online, and even after 30 minutes the character was not logged out.

1 Like

I know entire guilds with this problem i know arena teams that have this problem this is 100% from blizzards side.

2 Likes

Now happening in BGs too. Stuck half-way at loading screen to WSG. Second time. The first time was stuck without the progress bar progressed.
Happened to a friend yesterday upon trying to enter arena, I entered arena, he was stuck on loading.
Of course the problem is Blizzard side.

1 Like

Been happening to me too… since this week and its more intense last 2 days from reset.
Right now, its like playing the “Mines” game…which dung or map/zone i will get stuck on loading screen…and will i be even able to load in to game?..tooday take about 6min to get in to mythic0 Mechagon, but geting out?When i left the instance by portal(to summon one person) it happened again and i went for ALT+F4 after 10min has passed… -.- …this is not normal anymore…

1 Like

Thank you Blizzard for your contribution, but we all tried that and the issue is still around. Right now i am stuck on loading AV bg. A minute of 10 ago it was the same, this time the bar is at 100%, last time it didn’t even load. It’s been happening a lot this week. Please fix it. The queus are already way too long, to be stuck and start all over again.

2 Likes

Just had my raid disband because everyone that tried to walk out of Ny’alotha got stuck in a loading loop… We have never had an expansion with as many bugs. Get rid of Activision and start giving us quality programming again, please!

8 Likes

update: after losing few arena matches and getting kicked from dungeons I started using VPN, 50-60 more ms on my regular 100 ms but everything seems working correctly at least… there’s got to be a problem on blizzard’s end, specially if they added new servers or rent new ones… its a new problem like 2 weeks old or something. please someone from blues look into this problem. its been very annoying and frustating and its happening to quite some number of players regularly.

1 Like

I’m having the same problem. I made a group for a dungeon and as I entered through the gate, got stuck on 0% loading screen.

1 Like

hey i’m have the same issue . this is happening a lot for me past 2 weeks .

1 Like

I got same problem losing like 20game of arena cuz of arena loading screen freez

2 Likes

Funny that they’re not responding users! fun thing is its only happens in bfa loading screens not old expansions, I tried all of em and were fixed but BFa’s one? huh! The funniest thing happened to me was n uldum, wasnt able to see quest givers:D and as someone said, only VPN can handle this problem even if server ip is same as before but somehow it can fix it:D

yup, I got this issue as well and everything goes fine if I turn the VPN on…