Game doesn't work after 8.1 patch


#473

There has been numerous people here with supported video cards and still having same issue.

I for one keep on crashing on random activities with error log referencing to game memory library. Nothing such was prio 8.1


#474

I’m one of those using a supported card. And it is not yet outdated. Blizzard still claims viable cards that are weaker than mine.
Dear @Нервор, the problem is not some people whining. Problem is that Blizzard, under supervision of Activision, puts less and less effort in providing a good product. We are not the only ones having technical issues after this patch. If they would at least provide amazing content, as they did in past, the community would accept it. But they don’t. That’s why there’s going to be more and more complaining.

Unfortunately it will probably be up to AMD to fix this issue, as Activision Blizzard decreased the numbers of their product management teams.


(Geozyllane) #475

I think so, the main differences are:

  • Blizzard was based on a social network of gamers, which support them with money to work on better apps;
  • Activision is based on stakeholders, who want more and more money asap, and the users are not partners to support with high quality apps, but a pump money into. So, the developing is retarted as cheap as possible on the level of quality as is.

#476

Well, played beta Azeroth, was fine. Quit since last summer, just bought game and game time.

on my AMD is does not work, on my Intel (slow) it works but horribly.

Looking at this thread I guess I wasted my money.

Unbelievable!

EDIT: OMG after just letting wow run (black screen) for like 15 minutes at least (was talking to wife and smoking a cigarette in kitchen), it just works. Let’s see if it will work a second time.

EDIT2: hit the button system settings in game, and it froze.
EDIT3: restarting game, takes 10 min of black screen then char select.
EDIT3: hit the system button at selecting character screen -> freeze, waiting now. works
EDIT4: took about 5 min, disconnected from server, but system settings are there, can change them.


#477

welcome to the club.
Do tell if you gonna get any game crashes due to error 123 fatal exception


#478

So far none, been playing for 2 hours.

It just takes a very very very very very looooooooong time to load the game (black screen for about 10 minutes after battlenet log in and hitting PLAY button.

Intel HD graphics 3000 and AMD Radeon HD 6800M series in old HP-Envy17 laptop


#479

I have the same experience as Penumbraa.
Intel HD gfx 3000 and 6770M here. I didn’t know it would work if I waited enough time after trying it one hour ago.
I’ve had a terrible experience with support. They didn’t seem to care much about fixing the issue, and they seemed like they knew just what was going on, but were trying to keep face for the company. It’s disgraceful.


#480

btw on the Intel gfx-card wow starts fairly quickly after hitting PLAY button in battle.net, on the AMD (works), it seriously takes about 10 minutes of blank/black screen (and windows (7) says program not responding) for the game to actually start and to be able to select character. But it works.

Seriously about 10 minutes!!! NOT trying to pull anyones leg here, it works for me and yes, it DOES take that fracking long… (more dots)

EDIT: What support? From Blizz? LMFAO


#481

Sigh
Please, take a seat and read the system requirements. It states that the min supported graphic card is AMD Radeon HD 7850 2GB, while you use 6770M and @Penumbraa uses some of 6800M series which are less than required.
The game from 2018 may launch on 2011’s mobile graphic cards, but there is no guarantee that it will be stable. So, if your hardware isn’t compatible even to minimal requirements, why do you blame the company?


#482

Because it’s not about being below the min specs. It’s because they messed up their patch. I’ve tried my Intel HD graphics and it opens the game just fine, no crashes. Absolutely god awful FPS, but runs it.
I’ve tried it on an even worse computer, except nvidia GPU - runs it fine.


#483

Been playing all day, stable at manually set 30fps which is enough (NTSC TV’s was 25 fps).

So hardware is strong enough, just that little patch.

Only starting game and having to wait that long (12 minutes today) is annoying and could have/ can still be avoided.

Ah, and my AMD is a HD 6850M


#484

I have Radeon R5 M330 - before 8.1 there was no problem at all but after 8.1 I got the problem with launching the game, as most of you.

The game launches very long time till it will pop the character choosing screen. It usually takes about 5-7min on mine notebook.

Entering the “System” options only works while I am not logged yet into game (still have to wait some time to get there). In Advanced section I cannot choose R5 M330 graphic card, because there is no option like this. The game only sees Intel HD graphic card.

What I have done already was to install newest AMD drivers and set manually in Preferences of switching between graphic cards to launch Battle,net and WoW.exe with AMD graphic card.

The game doesn’t see my AMD card but it runs smoothly (ofcourse after the whole time I am waiting untill it launches). So - my guess - it is not anything with AMD graphic card but strictly with Game Client which fails some tests finding dedicated graphic unit, that’s why (I think) it repeats them few times (that’s why it takes so much time) till it will run the game normally but with not detected dedicated graphic card.

I don’t think you can say “You got outdated components - that’s why it fails” because I have tried few sets of PCs in my workplace. I have build PCs with old Core 2 Quad processors and old GTX285 or with old Core i7 920 boosted to 4.00GHz and GTX 460 and game still was running good. My guess is someone got paid to get rid of AMD users :smiley: joke :wink:


#485

Can you choose AMD card in any other game where this option is available?


#486

You got me there. I don’t even know, because I have nothing else installed on this laptop. So I cannot tell… What’s more I did not checked if I could set it before 8.1 because there was no need to do it.

But as I am thinking I got an idea that maybe it is something like this (it’s just my speculation):
AMD chip is to help Intel and to switch when it comes to gaming etc. So I don’t know if I would even be able to see AMD graphic card in Options of any title. (maybe someone can confirm or bust this). Because it is not a main graphic card in this machine. It is AMD Driver which tells what and when launch any program with AMD card. Maybe I am wrong, don’t know.

…but still I think it is a problem with client, not machine or my software.
Unfortunately I won’t reinstall my system to check would it help because I use this machine mostly to work and not for gaming.


#487

Something like that: in AMD+Intel switchable graphics there is only one active card - Intel, and the AMD switches on if there is any need of it and if not - it just offs. Probably the client is trying to find the second card, which it cannot see.
What driver version do you use, and the OS version?


#488

Well… for AMD I am running:
18.40.11.10-181130a-336525E-RadeonSoftwareAdrenalin
with Switching Graphic option set to run WoW on Maximum Efficiency for R5 M330
My OS is Windows 7 Professional SP1 x64bit (tired of using W10 so went back to good ol’ days)
rest of specs are like: i5/12GB of RAM/1TB HDD

That is what I think


#489

I switched from AMD to Intel 4000, the game ‘works’ but every 2-3 minutes it laggs very very hard so it’s still kinda unplayable. Any idea how I can fix this? The program you recommended didn’t make it better.


#490

What was your problem? Please describe it, along with OS version and graphic card.


(Regnilash) #491

Well I have AMD 7600M, the game launches after 10-15 mins but I can’t click on system so I can’t play. I also have Intel HD graphics 4000 which does launch the game, but every 2-3mins it lags very hard for 30sec. I have windows 8.1, game always worked perfectly before patch 8.1

Gerfze is me btw


#492

Regnilash, try this:

  • Open the game client,
  • Wait untill the Choosing Character Menu will show up,
  • Click “Back” to go back to the Login Screen in game client,
  • Click “System” option (you might wait 5-10 minutes at this point)
  • Lower your game settings and click “Apply”
    Then log in and check if it helped. I couldn’t open the System Settings while logged into game because my client was crashing and disconnecting me from server. It only worked for me to open it while not logged yet into game.
    You might also check in Advanced tab can you choose other graphic card instead your Intel graphic card.