Game doesn't work after 8.1 patch


(Regnilash) #493

I’ll try that, but did that fix it for you?


#494

I have different setup than you. I am running on Intel HD 5500 + Radeon R5 M330.
I did not needed to lower my settings. My game never crashed from playing the game. I already said everything about what I did few posts earlier.


(Regnilash) #495

Alright, thank you!


#496

hey aeiya,

i lowered my game setting and it helped :slight_smile:
hopefully i wont have any more problems in the future :smile:


#497

Greetings everyone,
I’ve been fighting with this issue for almost a week. It took me a lot of time and around 4 Windows fresh instalments, as well as several reinstallations of WoW and a number of other tech stuff trying to work around my registry, my drivers, my bios, compatibility issues, yada yada.
I read through ALL of the comments on this post, tried several things you guys suggested and nothing besides being able to run the game on my integrated graphics cards.

I have a Dell Latitude E6540, integrated graphics intel HD 4900 or something like that and an AMD Radeon HD 8790M and I was running on Windows 7x64. Just to give you guys a little bit of context, so you can see that I share a similar background to yours.

Again, I will emphasize, everything that was suggested here or by our lovely Blizzard employees was tried with no success whatsoever.

Now, I’d like to mention something particular to my case. Everything was working fine for me in 8.1 until, for a specific reason I had to format my computer. Mind you, I was previously using Windows 10 and for some reason I thought that, since I could, I’d go with Windows 7 x64.
So after everything that I witnessed here and after blaming my sloppy installments, the possibility of faulty drivers and GPU I figured there was just one variable missing - my Operating System.

I don’t know wether it’s on Blizzard’s or AMD’s end but the fact is that after upgrading my Windows 7 to Windows 10 WoW is working like a charm.

I know that some people here were running Windows 10 already but those seemed to be a minority and I think I read that in their cases they ran with compatibility to Windows 8.1.

I don’t think this is the best solution or a solution that we, the customers should figure out and WoW definitly shouldn’t be forcing me to pick Windows 10 until 2020, but there you have it, this fixed it for me.

If for some reason this still doesn’t fix your game, I’d suggest doing a clean reinstallment of your graphics drivers. AMD has guides on how to do that perfectly. Run several programs, windows update as well as Dell and Intel programs to check for missing drivers and just clean your system in general.

Note: I didn’t downgrade my graphics driver as some suggested, I think that is retarded and I’d rather unsubscribe than running a computer able to only play WoW.

Note 2: I only use Direct X 11, so I’m not sure wether you’ll be able to run DX12 with this fix.

If there’s any way I can further help you with, please reply.


#498

Hey Falkaos

I would love to try what you did, I currently use windows 8.1.
But a Blizz employee already told me that Both my Intel4000 and AMD 7600 are outdated, so is it even worth it to upgrade to windows 10?


#499

Hi guys, how you’re holding up?

I tried one more thing, which I kinda hesitated to do, because my integrated card is (probably weaker than the other one) not supported/does not match the minimum requirements. But I gave it a shot, ’cause what can I lose.
I went to the Nvidia panel, and chose the integrated card for WOW. I launched the game and it worked. It took me to the character screen, but my subscription ended last week, so I made a cross and used one of my tokens. Luckily I was able to continue and play. But I lowered all graphic settings to the ground, just in case. Now it is a retro-lego-pixel-party, buta t least it works. For now.
It runs nicely without any problems so far. I don’t know how will it work if I try to run an instance or go somehwere where a lot of people bashing eachoter, but I’ll test it.

So the funny thing is that my 3d card (Nvidia) is supported and matches the requirements and it no longer works with wow SINCE the patch, my integrated card (Intel) is not supported/too weak and it works (at least for now).

So…what the bakers salty pretzel is going on? :dizzy_face:

I really hope this will be fixed and all of us can finally go back safe.

Stay strong bros and sisters ! :worried:


#500

game crashing randomly over and over 5-6 times a day and takes 10min to start up again. one day it will fix itself just as magically as it went broken!


#501

Crimsontex, have you tried to lower settings like I said before? So trying to get to System Settings before logging into the game with your character?

Falkaos, if you have bought your notebook with already installed Win10 it might be also like your processor or graphic card was not compatible with Win7. (but [as I keep thinking about it] it’s probably not it, if the game was running well before patch 8.1)
It’s like if you will buy newest laptop with (for example) i5 8thgen processor you won’t be able to install Win7 on it because Intel has 0 drivers for this chip for Win7. Well… you will be able to install the system, but it will not be running perfectly…
Still glad you made it in the end.

Lilblindcrow, have you tried to look in “System” options in “Advanced” tab? Can you even see the Nvidia graphic card of yours? I have not felt problems with any Nvidia card yet. What nvidia card do you have?


#502

i will try but i hardly can imagine that would somehow help.
Most of additional graphical settings like shading and such are disabled already. game itself run perfectly fine at 4 out of 10 (30fps+).


#503

My graphic card is Nvidia GeForce GT 630M, my integrated one is Intel ( R ) HD Graphics 4000. (According to the requirements-page my Nvidia card should be decent :no_mouth: )

I’ve checked it where you said, and there are 3 options:

  • auto detect
  • Intel R HD Graphics (low power)
  • Nvidia GeForce GT 630M

It was on ’auto detect’ and I left it hat way (for now). Tbh I don’t want to risk anything now that it finally works. :worried:


#504

With regard to your card’s suitability, it is of great importance to note that the model numbers are not sequential in terms of power or capabilities, except within each series, the 500/600/700/900 series of the Nvidia cards should be considerably separately for sequence. The sub-part ie. for a 630, the -30, is more likely to be a match for comparison to the minimum requirements.

It’s not quite as clean as that though, to know where your card stands, you would need to look at a graphics card (GPU) hierarchy chart, such as the one on Tom’s Hardware (google: graphics card hierarchy). The GT 630M is quite some distance below the minimum specced GTX 560. They really have upped the requirements a great deal on the graphics cards. Note that screen size matters a lot to how a card will cope, I only have a GT 730 (which isn’t much difference to the 630), but I only run 1024x768, which is the minimum resolution, far less for the card to do than a big screen output, so it copes. [At least it would if I could get the 8.1 patch to work, but that’s a different issue.]


#505

Sadly I’m not an expert on this (Yes, I’m the I-just-play-on-my-computer-but-I-don’t-know- a-s*1t-about -it-person. And yup I needed to spend a lot of time of these weeks researching information about my cards :slightly_frowning_face:).

I tought that my card is the part of the 600 series/family/group/clan/sect, therefore decent, because Nvidia 600 was present among the supported cards and came out later than the 500 series. So I tought if they are newer than they must be better. (At least I tought that would be logical.)

So thank you for telling me this. :slight_smile:

(But even If I was wrong about it it is really strange that everything woked fine before the patch came.)

Thanks for the help :wink:


#506

Hello guys,

I tried everything, support couldn’t help me either.

Here what worked for me:

  1. Launch Battle net client

  2. Navigate to WoW game

  3. Click Options

  4. Click Game Settings

  5. Check Additional command line arguments

  6. Enter -d3d11 in input field which is displayed

  7. Click Done

  8. Try to launch the game

Note: I am using Windows 10, which uses DirectX 12 as an integrated version which can’t be changed. Steps above are for running the game in DirectX 11 mode. I have also installed the newest GPU drivers previously.

Please, let me know if this worked for you as well.

I’ve lost 7 days of my subscription because of this. But I have tried everything, even reinstalling the system. Blizzard support wasn’t very helpful in my case.


#507

This has been mentioned here several times and not a 100% solution to the issue.

As regards to the game crashing issue:
Setting SET worldPreloadNonCritical to 1 in config.wtf seems to help abit. game still crashing but not as often. Instead now it lags for few seconds where it usually would crash.

Use to be forced to set it to 0 in order to fix 7.1 dalaran 5 min loading screens.

Also suggesting to buy new gpu is rather redundant specially when existing one is still works perfectly fine in every other needed aspect.

Considering the fact that next patch of this shinny game can mess up / fix everything allover (regardless of your gear) it is just not a wise thing to do.


#508

still nothing…


#509

I’m done. Fixing this game every day or 2 is really boring… I’ve just unsub WoW.


#510

Unsubbing aswell…

It is ridiculous how Blizzard treats their customers, not even replying to a post with nearly 10k views…

Can’t believe how they are ruining their customer support and community management.

@Blizzard:
Chatbots will not help you with everything here!


@Blizzard Community Support
#511

Unsub too same problem here 2nd week…


#512

Nothing for 6 weeks…