Huge latency spikes every several minutes

Hi! I’m about to just give up and stop playing, but I’ll try asking: since early January, every 30-40 minutes I get a huge latency spike (up to 6000 ms), which subsides after 10-15 seconds. The game requires a restart then, and the key is ruined. This happens only in WoW, everything else works normally - and I’ve tried close to everything at this point:

  • my ISP replaced all cabling, swapped a router, and they tried reconfiguring to a few different settings,
  • tried it via wi-fi (I normally use wired),
  • checked the issue on a PC, and 2 different laptops,
  • still blaming my ISP, I tested if the issues remains over phone USB tethering (mobile data) - and lo! is still remained,
  • deleted all addons + their configs and reinstalled the game,
  • reinstalled Windows,
  • changed all settings in WoW: audio, graphics (from very high to very low)), and network,
  • tried an external network adapter.

And nothing helped. So if it’s not my setup (happens on all devices), and not my ISP (the issue persits on usb tethering from mobile data), then it’s clearly on the other side of connection.

I’ve been playing WoW for several years, and this is the first time I might have to quit the game I love over such a ridiculous technical issue. Please try to help me :frowning:
I can’t include winmtr results from the WoW EU test sever since I get “you can’t include links”. Sigh.


When was the last time you did a ipconfig /flushdns

First lags i had last year but it was like once in every 2-3h, at the begining of this year once in every 1h, in last week i get lag like once in every 10 mins. I wrote about that in few diff topics, sent a ticket and the problem still exists. Ive done everything Blizz wanned, at the end they blamed my ISP, and my ISP says everything is OK on their side…

1 Like

Yesterday. I’ve tried it already :frowning:

Have you checked your task manager to see what is running while in the game… Typically with a high rev like this tend to tell me that something is attempting to install or load very similar to having your browser open it wants to update. In other words it’s suggested that you close all open apps and web browser. Do you have add-ons, web browser open or other apps running, music etc Have you disconnected your router/gateway/hub allowing it to reset have you bothered to switch cable ports in the hub/router are you even running on a hardwire or using wifi

Yeah, I did. Nothing at all - it’s just WoW that uses resources, and I even changed the process’ priority to high. Tried it on a fresh Windows with everything closed - the issue persists. I’ve tried both ethernet and wifi, replaced all cabling, and the router itself as well.

1 Like

The trick i used to use to get around that is put the link inside preformatted text, think that still works (it won’t be clickable but easy for people to copy and paste) or you could just copy and paste the results into you post.

Just linking this thread as it’s looks like the same issue.

Hey, good idea. Attaching it below, shame though I can’t include PingPlotter from the moment of spike as it has no export to txt option.

|                                      WinMTR statistics                                   |
|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
|                    -   14 | 1640 | 1415 |    0 |    0 |   24 |    0 |
|                    -   28 | 1213 |  881 |    0 |    0 |   19 |    1 |
| -    0 | 2516 | 2516 |    0 |    1 |   30 |    1 |
| -    0 | 2515 | 2515 |    1 |    1 |   38 |    1 |
| -    0 | 2515 | 2515 |    1 |    2 |   24 |    2 |
| -    0 | 2515 | 2515 |    8 |    9 |   46 |    9 |
|  -    0 | 2514 | 2514 |    8 |    8 |   51 |    8 |
|    -    0 | 2514 | 2514 |    9 |    9 |   39 |    9 |
| -    0 | 2515 | 2515 |   38 |   40 |   80 |   39 |
|   -    1 | 2510 | 2509 |   36 |   38 |  104 |   36 |
|  -    1 | 2479 | 2470 |   29 |   33 |  133 |   43 |
|     -    3 | 2304 | 2254 |    0 |   44 | 4444 |   33 |
| -    4 | 2135 | 2051 |    0 |  109 | 4577 |   31 |
|                   No response from host -  100 |  509 |    0 |    0 |    0 |    0 |    0 |
| -    1 | 2447 | 2430 |   29 |   29 |   73 |   29 |
|                 -    1 | 2446 | 2428 |   29 |   29 |   48 |   29 |

Had exactly the same issues and everything stopped after using a VPN.

If I have to start using VPN just to play WoW, I’d rather just unsub from the small indie company who cannot even provide assistance with this. I’m so done.

1 Like

That is true. I have seen recently many people posting the same issue and still no Blizzard’s response on that.

1 Like

Btw I tried sumbitting a technical issues ticket, and got a “can’t submit a ticket” error. So I tried submitting a ticket about not being able to submit a ticket in a different category and got “something went wrong on our end”.

Does anyone still work in their CS?

When I read your issue, it’s as if I’d describe mine.

Could people

stop with the /flushdns command thingie? It’s as if that is the magic trick, lol. If you reinstalled entire windows, shutdown your network modem, etc… The flushdns already happened, this command just forces it manually.

I think that you can try and contact people at blizzard directly by submitting ticket.

I didn’t try reinstalling windows, and for damn sure I won’t be doing that, but I did all the other things you did + I tried to have a chat with chatGPT :stuck_out_tongue: For the sake of tips/tricks in fine tuning some network card settings/ registry edit and whatnot. Nothing has helped my case. I also can say that sometimes game just works fine, but most of the time it doesn’t. It happens only in group content. Both in Wrath and Retail/ M+ and Raid. Discord works and I can hear people talk for example, but game just have 2k ping and says nope. Im also on the verge of giving up playing :slight_smile: I’ve been only stressed out recently, because whenever I wanna do something that I consider fun, I get the opposite /ruin keys/waste people time in failed m+ run, etc.


Exactly. I don’t want to ruin others’ keys, so I’ve just stopped logging on these last few days - there’s no point in playing if I can’t actually play.

I can’t submit a ticket though, I keep getting the “can’t submit” error:

And trying to submit it in a different way ends up with much the same:

Just for giggles I tried submitting a ticket in the “payment issues” category, and what a surprise - had 0 issues then…


I have exactly the same problem.
It has been going on for about two weeks now.
I have tried ALL the solutions I found on the internet to fix this problem.
All without the expected result.

Contacting the ISP, replacing cables, resetting the router, testing various router settings, typing commands in cmd, changing dns, formatting the disk, reinstalling Windows, changing Windows version from 10 to 11, disabling addons, changing computer settings, changing WoW settings, performing a dance to make it rain - none of these things helped.

Every day, every 5-15 minutes, the game freezes for several seconds, the ping reaches 2000 ms - which makes any activity except for Disturbed Dirt farming impossible.

Dear Blizzard - help, please… : >


I was in touch with ISP right now (kudos to them for actually caring about that) and they said it’s crystal clear that there’s a faulty node on the way at the “br01-eqam1” site (GoDaddy). So the only thing we can do is keep bumping this thread up, so it gets noticed eventually and Blizz does something about that.


Can you please narrow down which vpn location are you using to stop these delays from happening?

Btw on us forum they have this same problem as we have.

So the funny thing is I am using right now my own location - Poland. First I tested Germany and Denmark and it worked well but for curiosity reasons I switched for a whole day for my own location and it works fine. This is a very weird issue.

My ISP didn’t detect any issues on their side. My internet connection works perfectly outside of WoW so I really don’t know what’s up. I will be testing other countries in the upcoming days.


It is a weird issue, yeah, and all I want is a blue post saying “we’re aware of the issue and working on it” - however long it’d take. But right now it feels like if anyone from CS shows up it will be the usual “contact your ISP, it’s something on your end”, when it’s hundreds of people. Asked several friends and about half of them can’t even play. And every day seems to be worse than the last.

1 Like