[Mac] Fps being lower by 20-30 after 9.0.5 (no addons used)

As title says, after patch his servers today, my fps droped by around 20-30 anywhere in wow and all drivers are up to date and i asked in general chat does anyone else have this problem and alot of people said yes.

Update on fps problem. I noticed that my warlock who is necrolord and has all anima conductor streams up has alot lower fps on same spot from my alt who isnt necrolord. here is proof.

i tried with and without addons. they don’t affect it. druid is normal usual fps, while warlock is necrolord and whole maldraxxus is kinda like this for that character

PC windows 10, not mac


What hardware do you have?

I am having the same problem. I am running an iMac 2017 Radeon Pro 570 4 GB (don’t make fun of me) and since the update FPS lowered by 20-30 FPS

1 Like

I have the same issue, after patch in Ardenweald it’s all laggy and fps dropped around 10-20.

Same issue, lower avg/min/max fps everywhere.
Running an RTX 2070S, 3900x & 16 gigs of ram.
The fps is worse without addons than it was with addons before the patch. Lmao.

EDIT: My fps seems to be fixed after reapplying all graphical settings (even thought they did not seem to have changed), deleting blizzard cache from programdata folder and deleting the cache named folder from retail folder.

Same here on a Mini M1 with no add-ons, i dropped my quality setting to 1 and it still fluctuates from 30 to 50fps.

I also tried disabling V-sync and my monitor crashed within 5 seconds.

Not getting any Console crash reports either, not sure what else we can do to troubleshoot.

It’s great we see another MAC user <3

Same issue.

My PC has an integrated GPU, 16gb ram, decent CPU, SSD. I play with all on low and resolution scale 50%.

Before the patch, I didn’t have any problems at all with my FPS, but today after the patch I’ve noticed that the game is not very smooth in open world and dungeons. It’s definitely noticeable in gameplay as well, i dropped around 10-15 FPS.

I don’t know why. No settings have been changed, windows is up-to-date and absolutely nothing seems to be changed graphics wise. Blizzard did seem to make some undocumented changes though because now I can see certain things on some bosses that I didn’t see before…

this is very bad!!! 20 to 30 loss, either it gets fixed or it’s the end of wow for me.
Spires is the worst castle is fine

1 Like

I also have lower FPS since patch. About 20 FPS lower and stutter in some areas. Before patch no problems!


Since updating the game and logging in I’ve noticed incredibly low fps change. I used to be able to run around in Revendreth at 70-90 fps. I logged in and it was 3 fps very choppy, I reloaded the game then it changed to 30.

I’ve not changed anything since last night, I’ve looked at my EVGA Precision X1 and my GPU fans are cool and looked at Speccy and my CPU fans are cool.

I’m really not sure what has changed or what has broken this.

I also have FPS problems since the patch. Just last night everything was fine, the patch surely broke something. I’ve seen other people having FPS issues as well since the patch, but I’m not sure if blizzard looks on the forum and if they do if they will even take fixing this into consideration until 9.1 at least…

I dont have FPS problems but im 100% sure i have less from what i had before.

99.99% of the time this is related to outdated addons. Either disable or update them.

1 Like

lost 20 to 30 fps addons all disabled, can’t do M+ now…

hope you fix this!!!

here was lagging too,disabled handy notes addon,updated the rest,deleted cache folder ,fixed!

I definitely see a problem with fps not related to any addons, just a 10-20% decrease, what especially noticeable in the Spires of Ascension .
9600k stock, rtx 2070, 200% render

1 Like

Didn’t work, cleared cache folder, disabled all addons, turned off antivirus, scanned and repair game files, updated nvidia drivers, game settings are exactly the same. lost 20 to 30 fps.
yep spires is impossible to play now!

1 Like

yeah then should be something with the patch…:confused: