Unable to get Servant of N’Zoth quest

Hi every one,
i read a lot of topic about that toy. I’ll trying from a month doing every things to let the quest pop but nothing.
Last try in 23/07/21 and nothing.
I send a lot of bug feedback in this month for that quest.
Can some of you have news about that?
Thank you for patience

You are doing it in BFA zones right? It was hotfixed in 9.0.2 I belive, it can no longer be done in Shadowlands, for Lore reasons.

Ye but the quest not drop any way !

I’m sorry to say but the title is no longer achievable now. A lot of people tried getting it in Shadowlands (even BFA zones), and it seems it doesn’t pop anymore…
Maybe they will add it back some time. For now you are wasting time, sadly.

I don’t understand why they not fix it…. I take title in bfa zone like 1 month ago… but the quest for toy doesn’t pop :frowning: :frowning: :frowning: some gm can say some or at some one pop the quest in some way???

Can maybe fix in the 9.1.5???

Hi, don’t think they are going to fix it. As it’s not relevant for them. I already asked several times and reported the bug several times without any success.

take care.

Previous post : Unable to get Servant of N'Zoth quest

That’s sad :frowning: i ask more and more time to gm, he say that they are working for fix it. why any of them can say something about ? Or can change some with the new patch 9.1.5??

And please some GM can say something official about this issue??? Thank you

Hello, still nothing I assume ?
it’s more than one year by now…

Hi abelion, no answer by a GM. I have to try again in this days with some friend that need that toy too.

Have you tried these week ? O have some feed from some friend??

Hi, No more tries as we think they have no time to fix or even they abandon it totally. Even the GM said they know that there is a problem… I don’t think they are going to fix it as it’s something for only collectors or no more for the game progression sadly. Keep me posted on your side if you tried in vain anyway. take care ! ^^

Really sadly. The item is avaiable in game so why they don’t do nothing or say nothing ???

Well I guess we should continue to report the bug :wink:

Ye, i think the only way that we can do.
But some over there try if work recently???

The problem is how will you get assassin in the old bfa zones that noone plays, and after that kill 10 more players? Seems like impossible even if they fix the bug.

With a friend bro, just with a friends… but we have to know after tries tries and tries if they fix the bug and works…. We are texting from months, and any GM text something about until now…

1 Like

Thats not the supposed way to get it. It should be a rare title, earned the hard way back in BFA. Maybe it should remain removed…

It still in game, so if still in game is avaiable and can be good if they can fix it for try to get it… hard or not hard

The second quest where you killed your own faction had a debuff for 10 minutes on the killed player so you could not kill him again in that time to get quest progress. Could there maybe be a 10 min debuff in play here to but hidden since it is a enemy faction player that you killed? So either you or he can se it and that might be the thing that prevents you from getting the quest to pop.

In the same time getting assassin is not affected by it so then you start thinking it is bugged. Just a thought and theory since some seem to say they have gotten it recently.

I reach assassin but the quest don’t pop… the quest have to pop when you reach assassin rank… for this reason the quest doesn’t work…
if this not happen, is impossibile get the item for trying to kill some faction…
I try it with more than one char, with the azzinoth assault unlocked, doing all stuff necessery but the quest don’t pop…