WoW freezes when switching realms/login

So yeah, my WoW freezes when I come to the character screen or loading screen when switching realm/logging in/going into instance, what could be causing this? I’ve already tried deleting WTF and my addons and the cache and it didn’t work.

edit: It works just fine on PTR but on live WoW it freezes.
edit2: Going to reinstall it to see if that helps.
edit3: Apparently not? It’s just “Copying data” instead? What? Where is it copying data from when I deleted the folder?
edit4: That didn’t help, still freezing on retail but not PTR.

3 Likes

Hi Sileani,

When the game freezes, does it stay locked up completely (crashes?) or does it take a bit longer to load into the new realm screen or into the game? It is possible that something else in the background is causing a bit of trouble. Try and close background applications before testing again.


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi

It’s taking a lot longer to load and the graphics freezes up too. It’s only there on live realms, it’s not there on PTR so it would be weird if it’s a background application causing it considering it works fine on the PTR but not live realms… will try it but I doubt it will work.

If it was background applications, shouldn’t PTR be affected too and not just live?

edit: Made no difference, still freezes.
edit2: Recorded video of what’s happening when changing realms if that’s of any help.

2 Likes

Heya,

even if the issue is not present on PTR i would still try closing the background apps. Also, when did you first start experiencing this issue ? Was it after the installation of a certain app ? Was it after a windows update ?

I have tried with disabling backgrounds apps, which you would know if you read my post.

This is EXACTLY what happens to me, very frustrating.

Edit: There is actually an entire thread about this on General Discussion. I think it’s been there for a day or two.

Any idea of how to fix this?

I made a post about this in general Character screen and the huge delay in loading I did try with two machines, one is a bit older and takes a little longer but this is not an issue with background applications.

Mine is exactly like the changing realms video but does it when logging in too. I get the three “Connecting”, “Retrieving Realm list” then “Logging into game server” boxes then I can get the “The application is not responding” box to appear. It’s also doing the same delay after the character list appears sometimes.

For some reason the time is getting longer. Here are my GPU and CPU loads during the lockup. https://imgur.com/a/wnQKCu6 is an imgur link but this stupid new forum doesn’t allow me to post it properly.

If my Live Mail or Google Chrome are getting in the way then that’s bad programming by your people. So you know, the yellow icon was a program I shut down using “end task” but you know how windows keeps the icon there when you end task until you mouse over it, besides I’ve used that for a long time and it hasn’t affected it before.

Your Devs did something in the last patch and won’t admit it as that was when it started. Maybe they fresh load the characters every time which means there is a delay in the server or have added some kind of check.

Any idea how to fix this? Really getting on my nerves to have freezes and WoW becoming unresponsive every time I login, switch realms or I get a loading screen in the game.

Edit: What in the hell? I found out what’s causing the problem now, it’s discord. I can’t use discord while playing the game.

I found out what’s causing it for me, discord is. I can’t use it when playing or I get them freezes. WTF?

Edit: NVM, it still exists without discord but it’s far less severe than if I am running discord.

Clean install of Windows 10 and the problem persists. It’s clearly something on your side at this point, only thing I’ve installed is drivers for my graphic card and chrome.

1 Like

It’s been happening since 8.0 - deleting cache does temporarily solve the issue but it just returns after a few days.

2 Likes

Ive had it since bfa and reported in game, bug report a number of times.
Nothing running in the background, except win10 standard stuff, no add ons.

About time all these issues got fixed !

(also the one with the seconds of delay on opening prof window. etc)
Its not at players end.

1 Like

Trying a reinstall to see if it is fixed but why is it that I had 75GB free on the drive and I’m getting disk full until I restart the machine and it then goes to 38GB free?

It seems to be allocating double the space needed until a restart.

It’s on an SSD. Sandisk SSD SDSSDP 128GP

https://imgur.com/a/daXMcXK shows pre and post restart, nothing else was done and the download was complete.

The reinstall with addons back in place is now a 6-7 second delay, much better than it was. Without addons and a fresh install the delay was about 4-5 seconds. The music was stuttering though.

i have the same problem its getting really annoying now.

its so long now i remember when alot of players had this problem and now its still there.

usually a loading screen takes like 2-3sec for me but now its around 10~
same for switching realms or to other characters.

the problem is on blizzards end.
its a pain to do anything with this.
especially arena. :rage:

it take a bit longer to load

… A bit?! Bit!

Please, lets be honest here. It’s not a “bit” longer. If it was a bit longer, people would of shrugged it off and carried on their day.

Downplaying our concerns is not a good start.

As others have mentioned, I’ve seen this from the start of BFA. Probably before, I have memories of this being an issue since we had a problem at the end of Legion, where we could log on, but no characters were showing at all.

Since then it’s been the character list showing, a rendered shadow but no character and a 10-15 second wait before the UI was usable.

Since yesterday, it’s been a 45-60 second lock up instead of 15 seconds. The window shows as “Not Responding”.

Thank you for all the updates and checks everybody. Please do continue to report new issues related to this here, but know that it is being looked into.


Have a few seconds to spare? Let me know how I’m doing!
https://www.surveymonkey.com/r/Nenyasqi

I have the same issue.
Whenever I change realms, change characters, login, hearthstone, see a loading screen the game FREEZES (the screen/gfx) - My windows recognises the app as ‘‘frozen’’ (loading circle on mouse).
This happens for 5-10 secs, then it unfreezes.

This happens with or without addons, with or without new cache/wtf folders and since lately (like 2 months- BFA??)

Just reporting on my findings in case it is of use. I have the issue and so do all of the friends I regularly play WoW with. These problems didn’t exist at the start of BfA, only after an update or hotfix some time in October? The issues persist through WoW reinstalls, Windows reinstalls, driver updates, addon disables and different graphics settings.

  • After logging on, the character select screen appears showing the character list and the racial background but the background animations are frozen and the character model is missing. The character model appears around 5 seconds later and then everything works as normal.

  • When I change realm, the realm list appears as normal but when I select a realm, the character list background appears but really dark. After a 5 second freeze, the 1st issue then occurs (background there but frozen, with no character model). Once the character model appears it’s back to normal. The same happens the first time I switch to any realm. If I go back to a realm I’ve already selected in the same session, I still get the dark background freeze for 5 seconds but the character models appear instantly. It feels like the client is taking an excessively long time to retrieve the character info for each realm but then it’s being cached.

  • Loading screens taking much longer for first logon, especially when logging in to a BfA zone. Once the world loads initial performance is fine, no ping spikes or frame rate drops. I can play as normal once I’m in. I will randomly encounter excessively long loading screens but it’s inconsistent. For example BfA may be fine but then a TBC zone will take ages to load. Then later one BfA zone will load fast but then very slow a short time later.

  • When I open the in game map, the map window is grey for 2 seconds before the map appears. The behaviour continues as I try to click on and right click away from any BfA zones. Once I’ve right clicked back to the Azeroth overview, the map works normally with no delay when I select any zones that aren’t BfA content. Again, this happens the first time I click on any zone, then appears to cache and load faster but will go back to slow loading later.

As of 8.1 the issue is gone now. I’m not sure what it was in 8.0.1 that was causing it but it’s gone now. Just like it didn’t exist on 8.1 ptr.

for me it was disabling weak auras in the addon menu fixed it. not a big deal for me anyway cus i am no longer using the one little thing i got weak auras for in the first place this also cut the amount of ram my wow was using in half. so for me the issue was somehow weak auras after the 8.1 patch.