Video driver crash in World of Warcraft with AMD video cards (7900 XTX) on DirectX 12

This is exactly my issue too. I have an AMD card and WOW won’t start since the patch unless I use the workaround. But now every hour or two the game crashes with an out of memory message. I have 32GB RAM and last time I noticed it was using 23GB which seems a bit much for a game like this :stuck_out_tongue:


This is a long shot but I haven’t crashed last 2 days.
In AMD Adrenaline go to Gaming>Display and try to turn off Adaptive Sync Compatible (if its on).

Second thing I did was to enable virtual memory on my wow SSD.
Type ‘Adjust the appearance and performance of Windows’ in the search bar. (windows 11)

Open up the performance options and click on the ‘Advanced tab’

Under Virtual Memory, click on Change.

Check the drive wow is installed one and make sure the ‘System managed size’ is checked.
Restart pc after to apply changes.

No idea if this helps or if I am just having some good luck these days finally lol

1 Like

It seems they are working on the issue now

1 Like

Ok this wasn’t what this thread is about.
Let’s keep the issues in separated threads if possible.

This is about video driver crashes on AMD video cards, specifically 7000 series.
The issue is about video driver timing out, following by a black screen and recovering shortly after (or not - in which case the PC needs to be rebooted)

1 Like

Did you try making the suggested changes recently posted?

I am on 7800 XT and I have exactly the same problem described by Elderkain. DirectX 12 mode right now results in a eventual Driver Crash, black screen, and then it recovers from the crash about 8-15 seconds later. This makes DirectX 12 unplayable on AMD 7000 series cards.

Right now the only “solution” is to downgrade to DirectX 11, which seriously degrades game performance in larger gatherings (raids, major towns, open world events). With DirectX 11 AMD drivers no longer crash.

I wouldn’t call it a satisfactory solution, but it’s something while we wait for a fix.

I am currently on 23.11.1 drivers from AMD.

1 Like

DirectX12 is straightup broken right now, the moment I switch to it, my game freezes and not responding on 7900 XTX. While Directx11 has constant driver crashes as well, at stock settings + the current memory leak issue.

Only problem I have with RX 7900XT is that having render scale below or above 100% causes fps to be halved, otherwise works fine with DirectX 12. AMD drivers stopped crashing in WoW after I removed Adrenalin software and installed “Drivers only”. Now I use Afterburner to control GPU, Freesync enabled from monitor and Resizable BAR from BIOS.

Hi there, thanks all for posting about your recent issues with AMD graphic cards and DirectX12.

We’re already investigating into this from other reports, currently the only workaround is to use DirectX11.

Using DirectX11 though may mean you have to lower your graphic presets as well to prevent further performance issues while that’s being looked into for resolving.


Thank you for acknowledging this issue for us.
Looking forward to a fix.

If community can provide more logs or further info into this please let us know

1 Like

Hey, while you’re at it, could you look into the driver crashes happening in both retail and wotlk classic? Been happening since dragonflight and phase 3 in classic when the dragonflight engine was introduced. It’s happening for all AMD GPUs.

1 Like

Just chiming on, the issue still persists.

1 Like

Same issue

Bummer, I just received my 7800xt yesterday and was shocked when WoW wouldn’t even launch. At least it works in DX11.

For the Blizzard engineering team. I’m sure you noticed that the problems appear to have the following things in common:

Code: 141
Bucket ID: LKD_0x141_Tdr:6_IMAGE_amdkmdag.sys-SCH

A problem with your hardware caused Windows to stop working correctly.

Problem signature
Problem Event Name: LiveKernelEvent
Code: 141
Parameter 1: ffffaa09804b4460
Parameter 2: fffff8076ad14f60
Parameter 3: 0
Parameter 4: 8e20
OS version: 10_0_19045
Service Pack: 0_0
Product: 256_1
OS Version: 10.0.19045.
Locale ID: 1033

Extra information about the problem
Bucket ID: LKD_0x141_Tdr:6_IMAGE_amdkmdag.sys-SCH

One thing I’d ask is if we can get a blue post somewhere or update notes for when it is safe to run DX12 again?

It feels like, including in finding this issue, it is a problem that is swept under the rug, and you gotta go out of your way to find a solution ever since the 7th of November.

I’ve had to basically put my computer through the ringer only to find this 4 days later, and I don’t want to try again later for “maybe they fixed it now?” and damage my PC further than it already has in this russian roulette whether the bug was patched or not.

Indeed. It’s really stupid on their part to not have this as a message posted on the launcher “Hey stupid, we have a problem with DX12 and AMD 7000 series, run DX11 for now, or forever”.
Instead I had to reinstall my drivers and WoW and everything.

I’ll add my own two cents to this discussion.

Specs: Sapphire NITRO+ Radeon RX 7900 XTX, Ryzen 7 7800X3D, 32GB DDR5 RAM, 1000W PSU, Windows 11 23H2. AMD drivers are currently 23.11.1 but this has persisted for as long as I’ve had this machine for, since April.

Tried disabling FreeSync, DDUing my drivers and downgrading to non-Adrenalin versions, disabling MPO, purging the global shader cache, turning off HW acceleration in Discord, Steam, Browser. Virtual memory/pagefile is enabled on my SSD.

The driver timeouts happen both in DirectX 12 and 11 modes, although they seem much less common in DX11. I’ve run my GPU at stock settings and also tried undervolting.
(Different games have had issues where the GPU boosts up to unstable clocks when on stock settings and undervolting+capping the boost frequency has solved the timeout issues in those games.) The driver timeout issue in WoW does not seem to be connected to faulty boost behaviour, as I’ve seen the timeouts occur at ‘safe’ clock frequencies.

One thing I have consistely noticed that usually when a driver timeout happens it’s when I’m holding down RMB and turning my camera around. The game usually recovers after a driver timeout, but the cursor stays visible even when turning the camera. It’s probably a coincidence, but I have a hunch turning the camera and making the cursor disappear is somehow connected to the timeouts.

EDIT: Nah, I’ve gotten plenty of timeouts just idling after this post. The cursor does not cause the timeouts.

1 Like

I have 7800x3d + 7800xt.
Last night I had such a timeout with DX12 in a cave in Emerald Dream, where even after restarting the client it hanged immediately. First time that happened, but it hanged even withhout touching anything and cursor was visible, so I find it highly unlikely to be connected to the cursor.

Immediately after rebooting the client in DX11 mode the hanging stopped.

Usually the hanging has been just occasionally and I have been able to resume playing afterwards, but not yesterday. Had to add DX11 via console command to even be able to play.

Did you try the virtual memory on whichever ssd you have wow installed on?
I have the 7900 xtx and haven’t had a crash on dx12 since I changed that.