8.3 Memory leaks

8.3 is very buggy for a lot of people. It seems to freeze for 1-5 seconds, then crashes my graphics driver (short black screen or freeze) and then it resumes.

If you have task manager open in another window you can see WoW’s memory usage jump up several gigabytes while it is frozen. Sometimes it will drop to 350MB after a freeze and othertimes it will just keep increasing. Wow is using 11GB ram right now after about 3 freezes without restarting.

People on the US forums having the same problem:

This did not occur before 8.3 (I have not changed anything) and have tried turning off all addons, reinstalling the driver with DDU, scan and repair, etc

!!! EDIT: ----> Changing to Direct X 11 Legacy is a temporary fix, however it comes with a severe FPS penalty

EDIT2: @Blizz, I think it would be in order to refund our Horrific Vision tickets considering how unforgiving the system is and you guys releasing a clearly very buggy client.

EDIT3: Seems to have been fixed now

41 Likes

Do you get a blackscreen after the memory leak or first the blackscreen and then it ramps up?

1 Like

Having the exact same issue. At first I didn’t know, and the game eventually crashed prompting it exceeded available memory, thus resulting in termination. Monitoring as when it happens, so far my only take is a couple seconds after zone transition - but then again - happened after arriving at Boralus (from 5gb to 8gb) and then just when I got to portal room (jumped from 8gb to 11gb taken memory).

5 Likes

don’t even always get a blackscreen. sometimes it just freezes WoW (sound keeps playing) memory ramps up, and then it continues

12 Likes

I am having the same issues. Since this patch that my entire pc is breaking. Sometimes overall by black screens both of my monitors and then come back to normal, and other times just wow itself.

I made sure it wasnt addon related by making sure i have everything updated before i even started playing the patch. Including updating the graphics card (Gtx 660 ti) the day before.

So far it seems to be happening randomly, after portal room of the seal, after loading screens, during mob pulls. Its pretty much everywhere

4 Likes

Im having the same problems. Freezes occur every couple of minutes and last 5-10s. Also had one “Not enough memory” crash. All this started after 8.3 launched, never had these issues before.

8 Likes

As many others have already posted. Both here and on the US forums the game seem to have a severe memory leak after 8.3. I can run around fine for a decent amount of time with rock solid fps and all of a sudden for seemingly no reason the fps drops to 0. The cursor still works and everything else seems fine but the game remains frozen for about 5-10 sec until it picks back up. This started happening just after the patch to 8.3. Was also a showing up on the PTR.

EDIT: I can reproduce this issue pretty reliably. How is it taking so long to fix?

update: Today it happens more often for some reason. Pretty much every pull in islands. Never had this issue before. And no its not just bad fps. Its a lock for 5-10 seconds that is followed by every game asset “loading” in again. During this freeze i can alt tab and everything is working perfectly fine besides wow. Cursor is not locked and I can browse the internet or discord while it happens. Just WoW getting hardlocked for a period of time.

5 Likes

good evening. i have the same problem . before new patch everything was great . right now i cant play / enjoy the game because usually i have freezing issues. especially when i use mount and press c to watch my character. before patch i was playing the game at 8 to 7 and now i am trying to playing at 3 … also when i try to go to world quest location my game freezes for some seconds and i hear only the voices of each quest informations .

2 Likes

A couple of people on the US thread mentioned changing DirectX settings, so i checked mine and found they were reverted. Changed them back to DirectX 11 Legacy (from DirectX 11), and haven’t had any issues since. Hope it helps.

1 Like

It’d be very interesting to know which operating system people who are affected by this are using - mind sharing that here? :slight_smile:

win 10 build 1909

happens with both dx11 and 12

4 Likes

Win 10 pro, fresh update (yesterday) , got 16 GB in my rig
Most annoying symptoms in my case:

  • opening character tab © ->3-5 secs duration picture freezing. In that case many graphical elements of the char. window is missing. When the stack is over, the tab shows its full shape.
  • flying above an area of world quest and an announcement arrives -pop up window the relevant MPC advises what to do. (avatar on the left of the window, text on the left) - similar duration of freezing.
3 Likes

Win 10 fresh update 1 day ago, memory leak is worse than Google Chrome. The freezing happens for 1-5 seconds and both my screens go black for a second. Its extremely annoying and unplayable, except if I’m doing solo old content but thats not what a new patch is about am I right?

2 Likes

Same problem here. I get “Not enough memory” crashes and blackscreens and freezes like MANY more than enough to play the game ;/

I use macOS 10.15.2. I noticed the game runs better than before! Also, the memory usage is 3GB only. No freezes or crashes. Smooth as a butter.

Change directx 12 to directx 11 legacy working ! :stuck_out_tongue: Thx <3

2 Likes

same started happening for me, updating gpu drivers didn’t help
I’m on Windows 10 Home 1809 i know its an old build but hate updating if i don’t have to.
Changing dx11 to dx11 legacy fixed it for me but with that I lose some performance so would like this to be fixed

Win 10 Pro 64 bit. Build 1903.

16gb of ram. Baseline the game takes around 3,5. Then with each freeze its +2,+2 and so on.

Same here, one 5s freeze with blackscreen every 2 minutes.

Got 16gb RAM with windows 8 and GTX 960.

Really ruins my gaming experience.

If you just check how many ppl are suffering from this problem you would understand that its not about players system! sudden 5GB memory usage from wow is just about something in codes! and as raid will open in next reset, we all expect this problem get fixed, otherwise we’re *** ! cause you cant die or wipe whole raid because of game error!

5 Likes