Mac issues - CRASHING, LAGGING AND STUTTERING AFTER 8.3

After downloading 8.3, the game crashes completely or will lag for about 5-10 seconds with the rainbow mouse icon circling. The freeze spikes usually last for about five seconds in 8.2, and maybe occur 2-3 times a day. Now it appears every 5-10 seconds and make the game 100% unplayable.

Im not much of a tech guy. Posting the info of the Mac Im using and I beg there is someone that can help me with this.

Modellname: iMac
Model Identifier: iMac18,1
Processorname: Dual-Core Intel Core i5
Processor Speed 2,3 GHz
Number of Processors: 1
Total Number of Cores: 2
L2-cache (per kärna): 256 K
L3-cache: 4 MB
Hyper-Threading Technology: Activated
Memory: 8 GB
Boot ROM-version: 179.0.0.0.0
SMC-version (system): 2.39f40
Hardware UUID: 8C16BC1D-5D6C-5F3A-A291-5C984EEA1303

Note - they (Blizzard) also wanted the serie number but Ive seen posts in the US thread not to post it due to security reason, so I left that part out.
-screen: original “built-within” (bad English there, sorry) 21,5-tum (1920 x 1080)

Note that I’ve run all graphics on recommended and yet this freezes occurs.
Any ideas…?

EDIT: As we are following the same issue thread over at the US forums , the most recent blue post wanted additional information about the system we use. Updated that part.
EDIT 2: Whoops! Switched the Swedish words on the system info into English

The US thread -> https://us.forums.blizzard.com/en/wow/t/crashing-freezing-and-stuttering-after-83/411134

EDIT3: Forgot, here is the “crash info”

panic(cpu 0 caller 0xffffff7f9d172232): “Graphics firmware encountered an exception (eip: 0xf475, fault #: 0xd)\n”@skl/sched3/IGGuC.cpp:864
Backtrace (CPU 0), Frame : Return Address
0xffffff914d1ebb70 : 0xffffff8018f3bb1b
0xffffff914d1ebbc0 : 0xffffff80190733e5
0xffffff914d1ebc00 : 0xffffff8019064e5e
0xffffff914d1ebc50 : 0xffffff8018ee2a40
0xffffff914d1ebc70 : 0xffffff8018f3b207
0xffffff914d1ebd70 : 0xffffff8018f3b5eb
0xffffff914d1ebdc0 : 0xffffff80196d24f9
0xffffff914d1ebe30 : 0xffffff7f9d172232
0xffffff914d1ebe80 : 0xffffff7f9d0ead24
0xffffff914d1ebee0 : 0xffffff8019640ccd
0xffffff914d1ebf30 : 0xffffff801963f612
0xffffff914d1ebf70 : 0xffffff801963eb9c
0xffffff914d1ebfa0 : 0xffffff8018ee213e
Kernel Extensions in backtrace:
com.apple.driver.AppleIntelKBLGraphics(14.0.3)[1B1F5C29-179F-374D-BACF-919D3A83FBBD]@0xffffff7f9d0e9000->0xffffff7f9d1dbfff
dependency: com.apple.iokit.IOPCIFamily(2.9)[1286D5E5-A6A1-3C44-A244-04C068903DB2]@0xffffff7f9992f000
dependency: com.apple.iokit.IOSurface(269.6)[640503DC-6033-3EF6-85F4-F48282EF48DD]@0xffffff7f9bd54000
dependency: com.apple.iokit.IOGraphicsFamily(569.3)[7B5CA52B-0BD1-34AB-BFC9-7D5C3A0DBE7C]@0xffffff7f9caf9000
dependency: com.apple.iokit.IOAcceleratorFamily2(438.2.8)[9176E894-E24A-36BA-AFDA-0DB11F3F512A]@0xffffff7f9cb96000

BSD process name corresponding to current thread: kernel_task

Mac OS version:
19C57

Kernel version:
Darwin Kernel Version 19.2.0: Sat Nov 9 03:47:04 PST 2019; root:xnu-6153.61.1~20/RELEASE_X86_64
Kernel UUID: C3E7E405-C692-356B-88D3-C30041FD1E72
Kernel slide: 0x0000000018c00000
Kernel text base: 0xffffff8018e00000
__HIB text base: 0xffffff8018d00000
System model name: iMac18,1 (Mac-4B682C642B45593E)
System shutdown begun: NO
Panic diags file available: YES (0x0)

System uptime in nanoseconds: 10935917939817
last loaded kext at 7136308474241: >!UAudio 320.49 (addr 0xffffff7f9ceab000, size 434176)
last unloaded kext at 7233657558868: >usb.cdc 5.0.0 (addr 0xffffff7f9cae1000, size 28672)
loaded kexts:

!ATopCaseHIDEventDriver 3420.1
AudioAUUC 1.70
!AGraphicsDevicePolicy 4.5.21
@AGDCPluginDisplayMetrics 4.5.21
@fileutil 20.036.15
!AHV 1
|IOUserEthernet 1.0.1
|IO!BSerialManager 7.0.2f4
!AUpstreamUserClient 3.6.8
!APlatformEnabler 2.7.0d0
AGPM 111.4.1
X86PlatformShim 1.0.0
pmtelemetry 1
!AHDA 283.15
!A!IKBLGraphics 14.0.3
@Dont_Steal_Mac_OS_X 7.0.0
!A!IPCHPMC 2.0.1
!AThunderboltIP 3.1.3
|Broadcom!B20703USBTransport 7.0.2f4
eficheck 1
!A!IKBLGraphicsFramebuffer 14.0.3
!ASMCLMU 212
!A!ISlowAdaptiveClocking 4.0.0
!AMCCSControl 1.13
@filesystems.autofs 3.0
|!ABCM5701Ethernet 10.3.5
!ASDXC 1.7.7
AirPort.BrcmNIC 1400.1.1
!AVirtIO 1.0
@filesystems.hfs.kext 522.0.9
@!AFSCompression.!AFSCompressionTypeDataless 1.0.0d1
@BootCache 40
@!AFSCompression.!AFSCompressionTypeZlib 1.0.0
@filesystems.apfs 1412.61.1
!AAHCIPort 341.0.2
@private.KextAudit 1.0
!AACPIButtons 6.1
!ARTC 2.0
!ASMBIOS 2.1
!AACPIEC 6.1
!AAPIC 1.7
$!AImage4 1
@nke.applicationfirewall 303
$TMSafetyNet 8
@!ASystemPolicy 2.0.0
|EndpointSecurity 1
!AHIDKeyboard 209
!AMultitouchDriver 3420.2
!AInputDeviceSupport 3420.4
!AHS!BDriver 3420.1
IO!BHIDDriver 7.0.2f4
!AGraphicsControl 4.5.21
|IOAVB!F 800.17
!ASSE 1.0
DspFuncLib 283.15
@kext.OSvKernDSPLib 529
!AHDA!C 283.15
|IOHDA!F 283.15
@!AGPUWrangler 4.5.21
|Broadcom!BHost!CUSBTransport 7.0.2f4
|IO!BHost!CUSBTransport 7.0.2f4
|IO!BHost!CTransport 7.0.2f4
|IO!B!F 7.0.2f4
|IO!BPacketLogger 7.0.2f4
|IONDRVSupport 569.3
!ASMBusPCI 1.0.14d1
@!AGraphicsDeviceControl 4.5.21
|IOAccelerator!F2 438.2.8
X86PlatformPlugin 1.0.0
IOPlatformPlugin!F 6.0.0d8
|IOSlowAdaptiveClocking!F 1.0.0
!ASMBus!C 1.0.18d1
|IOGraphics!F 569.3
@plugin.IOgPTPPlugin 800.14
@kext.triggers 1.0
!AThunderboltDPInAdapter 6.2.4
!AThunderboltDPAdapter!F 6.2.4
!AThunderboltPCIDownAdapter 2.5.2
!AHPM 3.4.4
!A!ILpssI2C!C 3.0.60
!A!ILpssDmac 3.0.60
!A!ILpssI2C 3.0.60
!AThunderboltNHI 5.8.1
|IOThunderbolt!F 7.4.7
|IOEthernetAVB!C 1.1.0
|IO80211!F 1200.12.2b1
mDNSOffloadUserClient 1.0.1b8
corecapture 1.0.4
|IOSkywalk!F 1
usb.networking 5.0.0
usb.!UHostCompositeDevice 1.2
|IOAudio!F 300.2
@vecLib.kext 1.2.0
|IOSerial!F 11
|IOSurface 269.6
@filesystems.hfs.encodings.kext 1
|IOAHCIBlock!S 316.40.3
|IOAHCI!F 290.0.1
usb.!UXHCIPCI 1.2
usb.!UXHCI 1.2
|IOUSB!F 900.4.2
!AEFINVRAM 2.1
!AEFIRuntime 2.1
|IOSMBus!F 1.1
|IOHID!F 2.0.0
$quarantine 4
$sandbox 300.0
@kext.!AMatch 1.0.0d1
DiskImages 493.0.0
!AFDEKeyStore 28.30
!AEffaceable!S 1.0
!AKeyStore 2
!UTDM 489.60.3
|IOSCSIBlockCommandsDevice 422.0.2
!ACredentialManager 1.0
KernelRelayHost 1
!ASEPManager 1.0.1
IOSlaveProcessor 1
|IOUSBMass!SDriver 157.40.7
|IOSCSIArchitectureModel!F 422.0.2
|IO!S!F 2.1
|IOUSBHost!F 1.2
!UHostMergeProperties 1.2
usb.!UCommon 1.0
!ABusPower!C 1.0
|CoreAnalytics!F 1
!AMobileFileIntegrity 1.0.5
@kext.CoreTrust 1
|IOTimeSync!F 800.14
|IONetworking!F 3.4
|IOReport!F 47
!AACPIPlatform 6.1
!ASMC 3.1.9
watchdog 1
|IOPCI!F 2.9
|IOACPI!F 1.4
@kec.pthread 1
@kec.corecrypto 1.0
@kec.Libm 1

7 Likes

From what im seeing DX11 seems to be broken. In DX11 game takes almost 4gb RAM and in DX12 around 2.2GB. Crashing is caused by taking too much ram i guess.

1 Like

I have the same settings as you. So it’s def the graphic card

1 Like

@ Skorfhen

Ok glad you came and shared this. But really? I mean, I got a feeling that this must be an issue at Blizzards part. Ive done all stages on the “do this if game bugs for you” list and yet I cannot play.

Edit: 1 other thing. From one patch to another suddenly the graphic card is not enough? Been playing BFA since release on this iMac and only had 2-3 minor spikes per day. I have a hard time see this as a graphic card issue?

6 Likes

Sorry if i didnt phrase word correctly.
This is definitely something that has to do with the patch and that is either for Blizzard to fix temporarily and/or long term + display information about. But they play dead since this morning (they answer other posts, which means they prob don’t want to communicate on this or don’t have solution yet)

I was just implying that the problem as to do with the graphic card and memory, even if it’s something we can’t deal with (or from what i know)

Let’s try to find updates for that particular graphic card maybe and keep each other posted.

Skorfh

3 Likes

@ Skorfhen

No worries!

I just find it odd that in 8.2 it works close to perfect, and on the other second in 8.3 it not even playable. The difference is huge just over night all of a sudden.

Sounds good, lets keep each other posted if we can find a solution if not Blizzard has/had yet.

Edit:
Tried the HoO scenario once more. Worked fine the first 3-4 minutes. But then it started…and this time it totally crashed the entire Mac. It restarted itself. I hope this is solved soon…

6 Likes

They did not acknowledge the problem yet, but are collectif info in the US

4 Likes

I am having the same issue too.
I suggest we write the OS version, hardware and a small description as they do in US forums to help them fix it faster!

OS: 10.14.6 macOS Mojave
Hardware: Macbook pro 13 2017 (touchbar)
Issue: it happened in the maelstrom scenario, after a few seconds the game drops fps to 1-2, causes all the system to lag and after 10 secs the OS is unresponsive (mouse moves, wow music plays) and the only option is to hard restart the mac. No error codes appear.

As the US guys also say, it seems to be memory leak, maybe related to the new content areas, but it happened also 1 time at mechagon while killing a rare with other players around.

1 Like

@ Bilquis

Glad you share you issues. Yes it would be good if we could collect the feedback of OS here in this thread.

I also did another try recently to complete the intro scenario of HoO and Im giving up for tonight. Hope Blizzard have more insight of what’s wrong and praying tomorrow will be a better day for us OS users.

2 Likes

The same issue for me, started when I reached a puzzle game in Uldum. 10 sec lag and then game crashed at all and restarted OS.
macbook Pro 2017
processor: 2.3 GHz Dual-Core Intel Core i5
memory: 16 GB 2133 MHz LPDDR3
graphics: Intel Iris Plus Graphics 640 1536 MB
macOS: 10.15.2

1 Like

It doesn’t matter what version mac you have, I have tried it on both my Late 2016 iMac and 2019 Macbook and it crashes on both in the Halls of Origination at the puzzle bit.

MacOs Catalina 10.15.2 on both
Graphics: Intel Iris Plus and Intel Iris Pro

1 Like

I have another issue on my 5k imac

I have blurry graphics. So, when im select 5k ingame resolution (i have 5k system resolution) my fans become crazy. From 1200 RPM to 2700 RPM (i think its videocard issue, because rendering 5k textures is very hard). But when im turn on low graphics, my game become BLURRY, LIKE IM NOT SEEN EVER BEFORE.

What to do with this? Any ideas?

1 Like

MacBook Pro 2016, game was fine until 8.3 and now it’s unplayable. Crashed when I entered Dragon Soul and the puzzle bit of the quest chain. Please help Blizzard, I was looking forward to this expansion and it’s currently unplayable.

2 Likes

Same issue, the game is crashing on stage 6 of the HoO scenario. Beachball requiring a power cycle.

Late 2015 Retina iMac (21.5"); 16 Gb; 10.14.6; Iris Pro 6200.

Same issue. 8.3 is pretty much unplayable. Had zero issues before 8.3

Mac OS Version: macOS Mojave 10.14.6
System model: Macbook Pro Retina 2015 2.7 GHz Intel Core i5 8GB
Symptom: Regular freezing of game, usually (but not always) coinciding with periods of lots of activity on screen (pulling a lot of mobs/pressing a lot of buttons etc.) Happens in a lot of different scenarios. (First in Halls of Origination but also happens in Island Expeditions, 8.3 Zones, Horrific Visions etc.)

Lasts for around 10 seconds and either game then un-freezes or it lasts permanently. No error code. Often there is no way to navigate away from game nor close the WoW client/screen, the entire Mac freezes and the only way to solve is to do a complete Mac shut-down.

EDIT: This all happens on the lowest graphical settings with lowest (33%ish) resolution setting.

6 Likes

I can confirm this happens to me as well. Unable to play as the game freeze.

1 Like

Tried just to do open world stuff this morning such as Emissarie quests. Went perfectly fine the first 10 min, and then the stuttering began. At the fifth freeze, the Mac crashed and restarted itself.

A blue response here over at the EU tech forum would’ve been very very appreciated.

I have the same Problem on my MBP 2017 - Game freezes for 10 sec. every few Minutes. Cant play any high M+ Keys etc. and even the horrific Vision can get ruined by this.
@Blizz please fix this.

You would think after over 20 hours, 20 comments and 400 views that we would have a response to even acknowledge the issue by now.

5 Likes